aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-result/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 00:37:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-25 01:15:03 -0300
commitefc3db31fed77e74075918f40cc2a551c9e934b3 (patch)
tree9bd6d095908c5f86065e8edefc7d30cd959f7fb3 /testing/ocaml-result/APKBUILD
parentaa1e67d958632e694b8e93b6c3bcb01a76956548 (diff)
downloadaports-efc3db31fed77e74075918f40cc2a551c9e934b3.tar.bz2
aports-efc3db31fed77e74075918f40cc2a551c9e934b3.tar.xz
testing/ocaml-result: upgrade to 1.4
Diffstat (limited to 'testing/ocaml-result/APKBUILD')
-rw-r--r--testing/ocaml-result/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/ocaml-result/APKBUILD b/testing/ocaml-result/APKBUILD
index 579c12c12a..2f6f29506e 100644
--- a/testing/ocaml-result/APKBUILD
+++ b/testing/ocaml-result/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-result
_pkgname=result
-pkgver=1.3
-pkgrel=4
+pkgver=1.4
+pkgrel=0
pkgdesc="Compat result type"
url="https://github.com/janestreet/result"
arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml
@@ -12,21 +12,19 @@ depends="ocaml-runtime"
makedepends="dune ocaml ocaml-findlib opam"
options="!check" # no tests provided
subpackages="$pkgname-dev"
-source="https://github.com/janestreet/$_pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/janestreet/$_pkgname/archive/$pkgver/result-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
jbuilder build @install
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/usr/lib/ocaml
jbuilder install \
- --destdir="$pkgdir/usr" \
- --libdir="$pkgdir/usr/lib/ocaml"
+ --destdir="$pkgdir" \
+ --prefix=/usr \
+ --libdir=/usr/lib/ocaml
# Remove annotation files.
rm "$pkgdir"/usr/lib/ocaml/$_pkgname/*.cmt
@@ -46,4 +44,4 @@ dev() {
mv *.cmx *.cmxa *.ml "$subpkgdir"/$sitelib/
}
-sha512sums="eb65e5c3e122db1bb477169d83efc7e02b0c72d3ffdb0cdadf7fc92e28c4e3843d8a0ed28133641cbcb239236fa5c83144610c5de713db5c8f63d9f433d37ba9 ocaml-result-1.3.tar.gz"
+sha512sums="2e709fee6ceb54463c3989a90aed351c5b48f7a5edce9ccbba4d163cbfb795a19393be0d75885e762d4609961a64e273bb298b94bd3858dc2c20de9396b655d3 ocaml-result-1.4.tar.gz"