aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-xml-light
diff options
context:
space:
mode:
authorFernando Casas Schössow <casasfernando@outlook.com>2019-02-07 09:28:39 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 13:37:47 +0000
commitf188d2f85426c8314dd1151601a47e17fecfd2d8 (patch)
treecc0df3b40c45d55331e796b30015b7693c1280a3 /testing/ocaml-xml-light
parentf546733349d4ba39c527d65becd0e1acce638c85 (diff)
downloadaports-f188d2f85426c8314dd1151601a47e17fecfd2d8.tar.bz2
aports-f188d2f85426c8314dd1151601a47e17fecfd2d8.tar.xz
testing/ocaml-xml-light: new aport
https://github.com/ncannasse/xml-light Minimal XML parser and printer for OCaml
Diffstat (limited to 'testing/ocaml-xml-light')
-rw-r--r--testing/ocaml-xml-light/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/ocaml-xml-light/APKBUILD b/testing/ocaml-xml-light/APKBUILD
new file mode 100644
index 0000000000..1cd21f334e
--- /dev/null
+++ b/testing/ocaml-xml-light/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
+# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
+pkgname=ocaml-xml-light
+pkgver=2.4
+pkgrel=0
+pkgdesc="Minimal XML parser and printer for OCaml"
+url="https://github.com/ncannasse/xml-light"
+arch="aarch64 ppc64le x86_64" # restrict by ocaml
+license="LGPL-2.1-or-later-WITH-linking-exception"
+makedepends="ocaml ocaml-findlib-dev ocaml-ocamldoc gawk"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ncannasse/xml-light/archive/$pkgver.tar.gz"
+builddir="$srcdir/xml-light-$pkgver"
+
+build() {
+ cd "$builddir"
+ make all
+ make doc
+ make opt
+}
+
+check() {
+ cd "$builddir"
+ ./test.exe <<EOF
+<abc><123/></abc>
+
+EOF
+ ./test_opt.exe <<EOF
+<abc><123/></abc>
+
+EOF
+}
+
+package() {
+ cd "$builddir"
+ export DESTDIR="$pkgdir"
+ export OCAMLFIND_DESTDIR="$DESTDIR/usr/lib/ocaml"
+ mkdir -p "$OCAMLFIND_DESTDIR" "$OCAMLFIND_DESTDIR/stublibs"
+ rm -f test.cmi
+ make install_ocamlfind
+ install -D -m644 README "$pkgdir/usr/share/licenses/$pkgname/README"
+ install -D -m644 -t "$pkgdir/usr/share/doc/$pkgname/html/" doc/*
+}
+
+sha512sums="029068c6eb48cd1223438dc0f86e1c5e6fd0412d160ea4d79928eec5e5f5843af46260d7240e4260851e9580e7f92d578c764c63c8e0acab348637455493ef02 ocaml-xml-light-2.4.tar.gz"