aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocfs2-tools/tunefs-remove-op_query.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-23 21:56:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-23 22:18:39 +0200
commit4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b (patch)
tree710d95ee14b9815b21685d08b1d60ef864d148fe /testing/ocfs2-tools/tunefs-remove-op_query.patch
parentada13b6998155f1425ec53c9a6ceeac17a5cb7cd (diff)
downloadaports-4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b.tar.bz2
aports-4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b.tar.xz
testing/ocfs2-tools: rewrite aport and upgrade to 1.8.5
Note: We use the same ("unofficial"?) upstream as Fedora.
Diffstat (limited to 'testing/ocfs2-tools/tunefs-remove-op_query.patch')
-rw-r--r--testing/ocfs2-tools/tunefs-remove-op_query.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/ocfs2-tools/tunefs-remove-op_query.patch b/testing/ocfs2-tools/tunefs-remove-op_query.patch
new file mode 100644
index 0000000000..f3b35e7d21
--- /dev/null
+++ b/testing/ocfs2-tools/tunefs-remove-op_query.patch
@@ -0,0 +1,55 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Wed, 23 May 2018 21:14:00 +0200
+Subject: [PATCH] Remove query operation from tunefs
+
+tunefs.ocfs2/op_query.c uses glibc's printf extensions that are not
+available in the musl libc. I didn't find any standalone implementation
+and it's not trivial to implement them, so we must remove this feature
+for now.
+
+--- a/tunefs.ocfs2/Makefile
++++ b/tunefs.ocfs2/Makefile
+@@ -42,7 +42,6 @@
+ op_cloned_volume \
+ op_features \
+ op_list_sparse_files \
+- op_query \
+ op_reset_uuid \
+ op_resize_volume \
+ op_set_label \
+--- a/tunefs.ocfs2/ocfs2ne.c
++++ b/tunefs.ocfs2/ocfs2ne.c
+@@ -89,7 +89,6 @@
+
+
+ extern struct tunefs_operation list_sparse_op;
+-extern struct tunefs_operation query_op;
+ extern struct tunefs_operation reset_uuid_op;
+ extern struct tunefs_operation features_op;
+ extern struct tunefs_operation resize_volume_op;
+@@ -498,17 +497,6 @@
+ .opt_handle = handle_answer,
+ };
+
+-static struct tunefs_option query_option = {
+- .opt_option = {
+- .name = "query",
+- .val = 'Q',
+- .has_arg = 1,
+- },
+- .opt_help = "-Q|--query <query-format>",
+- .opt_handle = &generic_handle_arg,
+- .opt_op = &query_op,
+-};
+-
+ static struct tunefs_option list_sparse_option = {
+ .opt_option = {
+ .name = "list-sparse",
+@@ -652,7 +640,6 @@
+ &resize_volume_option,
+ &reset_uuid_option,
+ &journal_option,
+- &query_option,
+ &list_sparse_option,
+ &mount_type_option,
+ &backup_super_option,