aboutsummaryrefslogtreecommitdiffstats
path: root/testing/olm
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-29 13:37:51 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-06 00:25:14 -0300
commit84d377e1bed319de7fd7dff8471027b062f63e8b (patch)
treef2a3c129fa796c74b20f4c78fbdda0e479004c80 /testing/olm
parent20eddcb494f5f3f5597cab12227a6aa7b90b61c2 (diff)
downloadaports-84d377e1bed319de7fd7dff8471027b062f63e8b.tar.bz2
aports-84d377e1bed319de7fd7dff8471027b062f63e8b.tar.xz
testing/olm: new aport
Diffstat (limited to 'testing/olm')
-rw-r--r--testing/olm/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/olm/APKBUILD b/testing/olm/APKBUILD
new file mode 100644
index 0000000000..2c8ed9c6bd
--- /dev/null
+++ b/testing/olm/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=olm
+pkgver=3.1.2
+pkgrel=0
+pkgdesc="Implementation of the olm and megolm cryptographic ratchets"
+arch="all"
+url="https://gitlab.matrix.org/matrix-org/olm"
+license="Apache-2.0"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.matrix.org/matrix-org/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir/tests"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="78372140d8a0eb5b137ed5f324c52fd2e0000bb91f43eaf84e563dbbc16612d860243a13ba4517ab06e8433b6a68216bc70dfa6bad4e2f8fc3e5fec206a5d4a2 olm-3.1.2.tar.gz"