aboutsummaryrefslogtreecommitdiffstats
path: root/testing/omxplayer
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-27 08:45:44 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-27 08:46:14 +0000
commit93edf8b9cb587a262437fa17ecc73690f45487a2 (patch)
tree0dc288086775f11f324a6e2bfb31dffdc4ae305e /testing/omxplayer
parent3a49fdeb3ed63e395e1790f540c43ce889318fff (diff)
downloadaports-93edf8b9cb587a262437fa17ecc73690f45487a2.tar.bz2
aports-93edf8b9cb587a262437fa17ecc73690f45487a2.tar.xz
testing/omxplayer: new aport
Basic command line player for Raspberry Pi
Diffstat (limited to 'testing/omxplayer')
-rw-r--r--testing/omxplayer/APKBUILD52
-rw-r--r--testing/omxplayer/use-system-libs.patch23
2 files changed, 75 insertions, 0 deletions
diff --git a/testing/omxplayer/APKBUILD b/testing/omxplayer/APKBUILD
new file mode 100644
index 0000000000..4643660b4e
--- /dev/null
+++ b/testing/omxplayer/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=omxplayer
+pkgver=0.20131216
+_commitid=b34143cb3e678453ccae968d3a65c0cb5a34333e
+pkgrel=0
+pkgdesc="Commandline OMX player for Raspberry Pi"
+url="https://github.com/popcornmix/omxplayer"
+arch="armhf"
+license="GPLv2"
+depends=""
+makedepends="raspberrypi-dev ffmpeg-dev pcre-dev boost-dev freetype-dev dbus-dev"
+install=""
+subpackages="$pkgname-doc"
+source="omxplayer-$pkgver.tar.gz::https://github.com/popcornmix/omxplayer/archive/$_commitid.tar.gz
+ use-system-libs.patch
+ "
+
+_srcdir="$srcdir"/$pkgname-$_commitid
+
+prepare() {
+ local i
+ cd "$_srcdir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_srcdir"
+ cat <<EOF > Makefile.include
+INCLUDES:=-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux
+INCLUDES+=$(pkg-config --cflags freetype2 dbus-1)
+LDFLAGS:=-L/opt/vc/lib -Wl,-rpath,/opt/vc/lib
+LDFLAGS+=$(pkg-config --libs freetype2 dbus-1)
+EOF
+ make
+}
+
+package() {
+ cd "$_srcdir"
+ make dist DIST="$pkgdir" || return 1
+ rm -rf "$pkgdir"/usr/lib/omxplayer
+}
+
+md5sums="ae722a186555168545c61c5f1b10be53 omxplayer-0.20131216.tar.gz
+f012acde48e989a13fbd9351cb8bcf11 use-system-libs.patch"
+sha256sums="efac24685bfb142c2fae4ff5ebed824d6b6d03e01491044bbe558880b31ae1be omxplayer-0.20131216.tar.gz
+242c0efdbea973c9623e0ff861d19a842a055aef17884fbbcb87388b31767ed5 use-system-libs.patch"
+sha512sums="f61c9c4188c4001fa683ce574b5229c40d54bf0afed33d70ed7eae1ff1b8308880c208a67b65d071b419690b66601dcce6cab6799f7134994d43d27375df9f77 omxplayer-0.20131216.tar.gz
+84d184d499f5bc8326aa41bec70eff99855afedd726aacfc962ac5b9b9afed92cfd61a9d9b2f21e2f2af887b1c38cd1fc025a0ec6fd73eafcaf3c7b9d90ef857 use-system-libs.patch"
diff --git a/testing/omxplayer/use-system-libs.patch b/testing/omxplayer/use-system-libs.patch
new file mode 100644
index 0000000000..d51d0fdd73
--- /dev/null
+++ b/testing/omxplayer/use-system-libs.patch
@@ -0,0 +1,23 @@
+--- omxplayer-b34143cb3e678453ccae968d3a65c0cb5a34333e.orig/Makefile
++++ omxplayer-b34143cb3e678453ccae968d3a65c0cb5a34333e/Makefile
+@@ -46,7 +46,7 @@
+ $(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
+
+ version:
+- bash gen_version.sh > version.h
++ sh gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+@@ -65,11 +65,9 @@
+ make -f Makefile.ffmpeg install
+
+ dist: omxplayer.bin
+- mkdir -p $(DIST)/usr/lib/omxplayer
+ mkdir -p $(DIST)/usr/bin
+ mkdir -p $(DIST)/usr/share/doc
+ cp omxplayer omxplayer.bin $(DIST)/usr/bin
+ cp COPYING $(DIST)/usr/share/doc/
+ cp README.md $(DIST)/usr/share/doc/README
+- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
+ tar -czf omxplayer-dist.tar.gz $(DIST)