aboutsummaryrefslogtreecommitdiffstats
path: root/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-02-22 12:18:36 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-02-22 12:18:36 +0000
commit3d5683dc57fd84fb689a4b788818022b514713e4 (patch)
tree7988e122bea72013d7c2d149130ac3cf10526b13 /testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
parente558ed22f63a6cc58506924726f2dd557898c63a (diff)
downloadaports-3d5683dc57fd84fb689a4b788818022b514713e4.tar.bz2
aports-3d5683dc57fd84fb689a4b788818022b514713e4.tar.xz
testing/open-iscsi-grsec: new aport
Diffstat (limited to 'testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch')
-rw-r--r--testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch b/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
new file mode 100644
index 0000000000..6ca2a4eaba
--- /dev/null
+++ b/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
@@ -0,0 +1,33 @@
+diff -Nuar open-iscsi-2.0-871.orig/usr/Makefile open-iscsi-2.0-871/usr/Makefile
+--- open-iscsi-2.0-871.orig/usr/Makefile 2009-07-10 20:55:58.000000000 -0700
++++ open-iscsi-2.0-871/usr/Makefile 2009-11-12 00:58:16.467960344 -0800
+@@ -48,14 +48,14 @@
+ all: $(PROGRAMS)
+
+ iscsid: $(COMMON_SRCS) $(IPC_OBJ) $(INITIATOR_SRCS) iscsid.o
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ iscsiadm: $(COMMON_SRCS) $(FW_BOOT_SRCS) strings.o discovery.o iscsiadm.o
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ iscsistart: $(IPC_OBJ) $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ iscsistart.o statics.o
+- $(CC) $(CFLAGS) -static $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+ clean:
+ rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
+
+diff -Nuar open-iscsi-2.0-871.orig/utils/Makefile open-iscsi-2.0-871/utils/Makefile
+--- open-iscsi-2.0-871.orig/utils/Makefile 2009-07-10 20:55:58.000000000 -0700
++++ open-iscsi-2.0-871/utils/Makefile 2009-11-12 00:58:56.404623435 -0800
+@@ -6,7 +6,7 @@
+ all: $(PROGRAMS)
+
+ iscsi-iname: md5.o iscsi-iname.o
+- $(CC) $(CFLAGS) $^ $(DBM_LIB) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(DBM_LIB) $^
+
+ clean:
+ rm -f *.o $(PROGRAMS) .depend