aboutsummaryrefslogtreecommitdiffstats
path: root/testing/open-vm-tools-grsec/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-13 05:22:25 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-13 05:22:25 -0600
commitfb53480a1d667786b9d4372ea59e10c056e701fd (patch)
tree97aa5c3819936a597ce4bc02df8c7455d9fe5574 /testing/open-vm-tools-grsec/APKBUILD
parent91004dcb79bfd9d1c60bfd6523a742eaea80740f (diff)
parent74b7f75820760816c263e9188c1224cc6e8f5b13 (diff)
downloadaports-fb53480a1d667786b9d4372ea59e10c056e701fd.tar.bz2
aports-fb53480a1d667786b9d4372ea59e10c056e701fd.tar.xz
Merge ssh://git.alpinelinux.org/gitroot/clandmeter/aports
Diffstat (limited to 'testing/open-vm-tools-grsec/APKBUILD')
-rw-r--r--testing/open-vm-tools-grsec/APKBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/testing/open-vm-tools-grsec/APKBUILD b/testing/open-vm-tools-grsec/APKBUILD
index b2aaeea312..d71a02a892 100644
--- a/testing/open-vm-tools-grsec/APKBUILD
+++ b/testing/open-vm-tools-grsec/APKBUILD
@@ -15,41 +15,30 @@ _realname=open-vm-tools
pkgname=open-vm-tools-$_flavor
pkgver=2011.01.24
_pkgsubver=354108
-pkgrel=0
+pkgrel=1
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
license="LGPL"
subpackages=""
depends="linux-${_flavor}=${_kernelver}"
-makedepends="pkgconfig bash rpcgen automake autoconf glib-dev
- procps-dev libdnet-dev icu-dev
- gettext-dev linux-${_flavor}-dev=${_kernelver}
- "
+makedepends="glib-dev gettext-dev linux-${_flavor}-dev=${_kernelver}"
source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_pkgsubver.tar.gz
+ vmware-modules.initd
"
_builddir="$srcdir/$_realname-$pkgver-$_pkgsubver"
prepare() {
cd "$_builddir"
- for i in "$srcdir"/*.patch; do
- [ -r "$i" ] || continue
- patch -p1 -i "$i" || return 1
- done
- # workaround automake-1.10 issue
- # http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-found.html
- touch config/config.rpath
- aclocal -I m4 && autoconf && automake
}
build() {
cd "$_builddir"
- ./configure --prefix=/usr \
- --disable-unity \
- --without-pam \
- --disable-multimon \
+ ./configure --without-pam \
--without-x \
+ --without-dnet \
+ --without-icu \
--with-kernel-release="$_abi_release" \
|| return 1
cd "$_builddir"/modules
@@ -58,11 +47,14 @@ build() {
package() {
cd "$_builddir"
- mkdir -p $pkgdir/lib/modules/$_abi_release/misc/
+ install -D -m755 "$srcdir"/vmware-modules.initd \
+ "$pkgdir"/etc/init.d/vmware-modules || return 1
+ mkdir -p $pkgdir/lib/modules/$_abi_release/misc/
cd "$_builddir"/modules
- for MOD in `find -type f -name '*.ko'`; do
- install -D -m644 $MOD "$pkgdir/lib/modules/$_abi_release/misc/"
+ for module in `find -type f -name '*.ko'`; do
+ install -D -m644 $module "$pkgdir/lib/modules/$_abi_release/misc/"
done
}
-md5sums="b324efa55bb3f1198100cad838e9272b open-vm-tools-2011.01.24-354108.tar.gz"
+md5sums="b324efa55bb3f1198100cad838e9272b open-vm-tools-2011.01.24-354108.tar.gz
+f16058de6e4251a509f87017f1684887 vmware-modules.initd"