aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openimageio/boost-python.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-13 17:36:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-13 17:36:36 +0000
commitaf7f1328f46323a2bfa1361c28ba275ce06df8de (patch)
treed50761983cba9f06bc4df6ab9227ae2a5ab8b030 /testing/openimageio/boost-python.patch
parent2809c59d457163b6d9698ad15e8896c2b91a501b (diff)
downloadaports-af7f1328f46323a2bfa1361c28ba275ce06df8de.tar.bz2
aports-af7f1328f46323a2bfa1361c28ba275ce06df8de.tar.xz
testing/openimageio: fix detection of boost-python
Diffstat (limited to 'testing/openimageio/boost-python.patch')
-rw-r--r--testing/openimageio/boost-python.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/openimageio/boost-python.patch b/testing/openimageio/boost-python.patch
new file mode 100644
index 0000000000..c68d426311
--- /dev/null
+++ b/testing/openimageio/boost-python.patch
@@ -0,0 +1,12 @@
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index e58d372..649e9f3 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -18,6 +18,7 @@ if (NOT BOOST_CUSTOM)
+ # different names on different systems. Try the most common ones.
+ foreach (_py_lib python-${PYTHON_VERSION_FOUND} python
+ python${PYTHON_VERSION_MAJOR}
++ python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}
+ python-py${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
+ find_package (Boost QUIET COMPONENTS ${_py_lib})
+ string (TOUPPER ${_py_lib} _py_lib_name)