aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openimageio
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-13 17:36:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-13 17:36:36 +0000
commitaf7f1328f46323a2bfa1361c28ba275ce06df8de (patch)
treed50761983cba9f06bc4df6ab9227ae2a5ab8b030 /testing/openimageio
parent2809c59d457163b6d9698ad15e8896c2b91a501b (diff)
downloadaports-af7f1328f46323a2bfa1361c28ba275ce06df8de.tar.bz2
aports-af7f1328f46323a2bfa1361c28ba275ce06df8de.tar.xz
testing/openimageio: fix detection of boost-python
Diffstat (limited to 'testing/openimageio')
-rw-r--r--testing/openimageio/APKBUILD10
-rw-r--r--testing/openimageio/boost-python.patch12
2 files changed, 18 insertions, 4 deletions
diff --git a/testing/openimageio/APKBUILD b/testing/openimageio/APKBUILD
index 1dd4b1111d..333c254936 100644
--- a/testing/openimageio/APKBUILD
+++ b/testing/openimageio/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=openimageio
pkgver=1.8.13
-pkgrel=0
+pkgrel=1
pkgdesc="Image I/O library supporting a multitude of image formats"
url="https://sites.google.com/site/openimageio/"
arch="all"
@@ -16,6 +16,7 @@ makedepends="cmake giflib-dev zlib-dev boost-dev libjpeg-turbo-dev libpng-dev ti
jasper-dev opencolorio-dev"
subpackages="py2-$pkgname:_python $pkgname-dev $pkgname-doc $pkgname-tools"
source="$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-${pkgver}.tar.gz
+ boost-python.patch
"
builddir="$srcdir/oiio-Release-$pkgver"
@@ -29,11 +30,11 @@ build() {
-DUSE_NUKE=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DPYLIB_INSTALL_DIR=lib/python2.7/site-packages \
-DCMAKE_SKIP_RPATH=ON \
-DOIIO_BUILD_TESTS=OFF \
-DOIIO_BUILD_TOOLS=ON \
- -DINSTALL_FONTS=OFF \
- || return 1
+ -DINSTALL_FONTS=OFF
make
}
@@ -58,4 +59,5 @@ _python() {
mv "$pkgdir"/usr/lib/python$pyver* "$subpkgdir"/usr/lib/
}
-sha512sums="578d039399846f994dd8e4b94a7b56f2bcec45571c2144705fc4e2fe6a3e1d878d79a96c0484350d54b46eef7796d46becda9f5d50f266cd730f63d97af0650e openimageio-1.8.13.tar.gz"
+sha512sums="578d039399846f994dd8e4b94a7b56f2bcec45571c2144705fc4e2fe6a3e1d878d79a96c0484350d54b46eef7796d46becda9f5d50f266cd730f63d97af0650e openimageio-1.8.13.tar.gz
+6f2fa329a1854be4e0dd358a1d2e0134a53422b63b5bef161a4dddfb4416a66e614afd063b15d2af56ac131c511c28b1b8f50ca6d10f00342ac2f111a23a7f0e boost-python.patch"
diff --git a/testing/openimageio/boost-python.patch b/testing/openimageio/boost-python.patch
new file mode 100644
index 0000000000..c68d426311
--- /dev/null
+++ b/testing/openimageio/boost-python.patch
@@ -0,0 +1,12 @@
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index e58d372..649e9f3 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -18,6 +18,7 @@ if (NOT BOOST_CUSTOM)
+ # different names on different systems. Try the most common ones.
+ foreach (_py_lib python-${PYTHON_VERSION_FOUND} python
+ python${PYTHON_VERSION_MAJOR}
++ python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}
+ python-py${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
+ find_package (Boost QUIET COMPONENTS ${_py_lib})
+ string (TOUPPER ${_py_lib} _py_lib_name)