aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openjfx11/disable-sse2.patch
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2019-02-11 23:48:21 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-10-24 22:57:49 +0200
commit40247420d123ab342128ea409d5a949fe072eafe (patch)
tree3a19d4b1965e15c514b77a32b371b48c92dc8dc6 /testing/openjfx11/disable-sse2.patch
parent4e4d49d380a193970dee1295bea2cd886d0c6d34 (diff)
downloadaports-40247420d123ab342128ea409d5a949fe072eafe.tar.bz2
aports-40247420d123ab342128ea409d5a949fe072eafe.tar.xz
testing/openjfx11: New aport
Diffstat (limited to 'testing/openjfx11/disable-sse2.patch')
-rw-r--r--testing/openjfx11/disable-sse2.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/openjfx11/disable-sse2.patch b/testing/openjfx11/disable-sse2.patch
new file mode 100644
index 0000000000..db99780c60
--- /dev/null
+++ b/testing/openjfx11/disable-sse2.patch
@@ -0,0 +1,60 @@
+Description: Enable SSE2 on i386 and amd64 CPUs only
+Author: Emmanuel Bourg <ebourg@apache.org>
+Forwarded: no
+Taken from: https://sources.debian.org/patches/openjfx/11.0.2+1-1/08-disable-sse2.patch
+--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
++++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
+@@ -23,13 +23,16 @@
+ -Wformat-security \
+ -fstack-protector \
+ -Werror=implicit-function-declaration \
+- -msse2 \
+ -fbuiltin \
+ -DHAVE_STDINT_H \
+ -DLINUX \
+ -DGST_DISABLE_LOADSAVE \
+ -DGSTREAMER_LITE \
+ -ffunction-sections -fdata-sections
++
++ifneq (,$(filter $(CARCH), x86 x86_64))
++ CFLAGS += -msse2
++endif
+
+ ifeq ($(BUILD_TYPE), Release)
+ CFLAGS += -Os
+--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
++++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
+@@ -20,7 +20,6 @@
+ -Wformat-security \
+ -fstack-protector \
+ -Werror=implicit-function-declaration \
+- -msse2 \
+ -fbuiltin \
+ -DHAVE_STDINT_H \
+ -DLINUX \
+@@ -31,6 +30,10 @@
+ -DGST_DISABLE_GST_DEBUG \
+ -DGSTREAMER_LITE \
+ -ffunction-sections -fdata-sections
++
++ifneq (,$(filter $(CARCH), x86 x86_64))
++ CFLAGS += -msse2
++endif
+
+ ifeq ($(BUILD_TYPE), Release)
+ CFLAGS += -Os
+--- old/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
++++ new/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
+@@ -42,8 +42,11 @@
+ -Wformat-security \
+ -fstack-protector \
+ -Werror=implicit-function-declaration \
+- -msse2 \
+ -DGSTREAMER_LITE
++
++ifneq (,$(filter $(CARCH), x86 x86_64))
++ CFLAGS += -msse2
++endif
+
+ PACKAGES_INCLUDES := $(shell pkg-config --cflags glib-2.0)
+ PACKAGES_LIBS := $(shell pkg-config --libs glib-2.0 gobject-2.0 gmodule-2.0 gthread-2.0)