aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openldap
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-18 14:02:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-18 14:02:17 +0000
commitfde27b59c9fef51bdd66ff3f453f9a2678ab0024 (patch)
tree96fa14fcb39b1562498440a7b36c76bd9420e482 /testing/openldap
parent70f6b7df72309a8270470877ceda9805415a4224 (diff)
downloadaports-fde27b59c9fef51bdd66ff3f453f9a2678ab0024.tar.bz2
aports-fde27b59c9fef51bdd66ff3f453f9a2678ab0024.tar.xz
testing/openldap: new aport
LDAP Server http://www.openldap.org/
Diffstat (limited to 'testing/openldap')
-rw-r--r--testing/openldap/APKBUILD60
-rw-r--r--testing/openldap/openldap-2.4-ppolicy.patch13
-rw-r--r--testing/openldap/openldap-2.4.11-libldap_r.patch11
3 files changed, 84 insertions, 0 deletions
diff --git a/testing/openldap/APKBUILD b/testing/openldap/APKBUILD
new file mode 100644
index 0000000000..132e898d0b
--- /dev/null
+++ b/testing/openldap/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openldap
+pkgver=2.4.11
+pkgrel=0
+pkgdesc="LDAP Server"
+url="http://www.openldap.org/"
+license="custom"
+depends="db openssl uclibc"
+makedepends="db-dev openssl-dev groff"
+subpackages="$pkgname-dev $pkgname-doc libldap"
+source="ftp://ftp.$pkgname.org/pub/OpenLDAP/$pkgname-release/$pkgname-$pkgver.tgz
+ openldap-2.4-ppolicy.patch
+ openldap-2.4.11-libldap_r.patch
+ "
+
+# berkdb crypt ipv6 ssl
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib/openldap \
+ --enable-slapd \
+ --enable-bdb \
+ --enable-hdb \
+ --enable-crypt \
+ --enable-dynamic \
+ --enable-dnssrv=mod \
+ --enable-ldap=mod \
+ --enable-meta=mod \
+ --enable-monitor=mod \
+ --enable-null=mod \
+ --enable-passwd=mod \
+ --enable-relay=mod \
+ --enable-shell=mod \
+ --enable-sock=mod \
+ --with-tls=openssl
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+libldap() {
+ depends="uclibc openssl"
+ pkgdesc="OpenLDAP libraries"
+ mkdir -p "$subpkgdir"/usr "$subpkgdir"/etc/openldap
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
+ mv "$pkgdir"/etc/openldap/ldap.conf "$subpkgdir"/etc/openldap/
+}
+
+md5sums="920fedbbb5bc61c2ca52c56edeef770a openldap-2.4.11.tgz
+2524e490ba334a760fa57057c16da7a9 openldap-2.4-ppolicy.patch
+d19d0502f046078ecd737e29e7552fa8 openldap-2.4.11-libldap_r.patch"
diff --git a/testing/openldap/openldap-2.4-ppolicy.patch b/testing/openldap/openldap-2.4-ppolicy.patch
new file mode 100644
index 0000000000..c05790e3e2
--- /dev/null
+++ b/testing/openldap/openldap-2.4-ppolicy.patch
@@ -0,0 +1,13 @@
+diff -urN ./clients.orig/tools/common.c ./clients/tools/common.c
+--- ./clients.orig/tools/common.c 2007-09-01 01:13:50.000000000 +0200
++++ ./clients/tools/common.c 2008-01-13 21:50:06.000000000 +0100
+@@ -1262,8 +1262,8 @@
+ int nsctrls = 0;
+
+ #ifdef LDAP_CONTROL_PASSWORDPOLICYREQUEST
++ LDAPControl c;
+ if ( ppolicy ) {
+- LDAPControl c;
+ c.ldctl_oid = LDAP_CONTROL_PASSWORDPOLICYREQUEST;
+ c.ldctl_value.bv_val = NULL;
+ c.ldctl_value.bv_len = 0;
diff --git a/testing/openldap/openldap-2.4.11-libldap_r.patch b/testing/openldap/openldap-2.4.11-libldap_r.patch
new file mode 100644
index 0000000000..448249a3b5
--- /dev/null
+++ b/testing/openldap/openldap-2.4.11-libldap_r.patch
@@ -0,0 +1,11 @@
+diff -Nuar openldap-2.4.11.orig/servers/slapd/slapi/Makefile.in openldap-2.4.11/servers/slapd/slapi/Makefile.in
+--- openldap-2.4.11.orig/servers/slapd/slapi/Makefile.in 2008-02-11 15:26:49.000000000 -0800
++++ openldap-2.4.11/servers/slapd/slapi/Makefile.in 2008-10-14 02:10:18.402799262 -0700
+@@ -37,6 +37,7 @@
+ XLIBS = $(LIBRARY)
+ XXLIBS =
+ NT_LINK_LIBS = $(AC_LIBS)
++UNIX_LINK_LIBS = ../../../libraries/libldap_r/libldap_r.la $(LTHREAD_LIBS)
+
+ XINCPATH = -I$(srcdir)/.. -I$(srcdir)
+ XDEFS = $(MODULES_CPPFLAGS)