aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openrct2
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-10 22:29:19 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-10 17:40:55 -0300
commitced8b9855c9994022db4245e74220b582b8116a3 (patch)
tree2a82b1d81d38e5c31a71a571ff20bebd247b383d /testing/openrct2
parent5b96ad4e358041915892d7a60bdeedbf6be318d6 (diff)
downloadaports-ced8b9855c9994022db4245e74220b582b8116a3.tar.bz2
aports-ced8b9855c9994022db4245e74220b582b8116a3.tar.xz
community/openrct2: move from testing
Diffstat (limited to 'testing/openrct2')
-rw-r--r--testing/openrct2/APKBUILD61
-rw-r--r--testing/openrct2/openrct2-cli.post-install16
-rw-r--r--testing/openrct2/openrct2.post-install16
3 files changed, 0 insertions, 93 deletions
diff --git a/testing/openrct2/APKBUILD b/testing/openrct2/APKBUILD
deleted file mode 100644
index 71c9b5e7df..0000000000
--- a/testing/openrct2/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=openrct2
-pkgver=0.2.2
-_pkgver_objects=1.0.9
-_pkgver_title_sequences=0.1.2
-pkgrel=1
-pkgdesc="Open-source re-implementation of Roller Coaster Tycoon 2"
-arch="all !s390x" # Build fails on s390x
-url="https://openrct2.io"
-license="GPL-3.0"
-makedepends="cmake ninja jansson-dev libzip-dev libpng-dev speexdsp-dev fontconfig-dev curl-dev icu-dev sdl2-dev mesa-dev fts-dev unzip"
-install="$pkgname.post-install"
-source="$pkgname-$pkgver.tar.gz::https://github.com/openrct2/openrct2/archive/v$pkgver.tar.gz
- $pkgname-$pkgver-title_sequences.zip::https://github.com/OpenRCT2/title-sequences/releases/download/v$_pkgver_title_sequences/title-sequence-v$_pkgver_title_sequences.zip
- $pkgname-$pkgver-objects.zip::https://github.com/OpenRCT2/objects/releases/download/v$_pkgver_objects/objects.zip"
-subpackages="$pkgname-cli $pkgname-doc"
-options="!check" # No tests available
-builddir="$srcdir/OpenRCT2-$pkgver"
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build && cd "$builddir"/build
- mkdir "$builddir"/title && cd "$builddir"/title && unzip "$srcdir"/$pkgname-$pkgver-title_sequences.zip
- mkdir "$builddir"/object && cd "$builddir"/object && unzip "$srcdir"/$pkgname-$pkgver-objects.zip
-}
-
-build() {
- cd "$builddir"/build
-
- cmake -G Ninja \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DWITH_TESTS=ON \
- -DDOWNLOAD_TITLE_SEQUENCES=OFF \
- -DDOWNLOAD_OBJECTS=OFF ..
- ninja
-}
-
-package() {
- cd "$builddir"/build
-
- DESTDIR="$pkgdir" ninja install
-
- install -d "$pkgdir"/usr/share/openrct2/title
- install -d "$pkgdir"/usr/share/openrct2/object
-
- mv "$builddir"/title/* "$pkgdir"/usr/share/openrct2/title
- mv "$builddir"/object/* "$pkgdir"/usr/share/openrct2/object
-}
-
-cli() {
- install="$subpkgname.post-install"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/openrct2-cli "$subpkgdir"/usr/bin/openrct2-cli
-}
-sha512sums="dd02da50cb13ca7df95f1d7d1529829df5ad39d9a7eed1a4ce88891b4f6ef77e66f25efd9715a53da5180dcd22696de4a9cb8fbf8c9195b2d8fb83115775cb7c openrct2-0.2.2.tar.gz
-7592c5397ceb27347c127ae5c4f8e11d7ef2ff23c97f627b354f941894420f546ffdcff88e2348e42c82d182ccf620e739c745d894a9b5650a0d7d028b68a106 openrct2-0.2.2-title_sequences.zip
-2138115fcba8a92aaacd58749f1c5778dde997908f69d5287edc267e8225dbbaa4536768829c019f2966d694745726fd5201806ff889b4c4ac69d27283a0c387 openrct2-0.2.2-objects.zip"
diff --git a/testing/openrct2/openrct2-cli.post-install b/testing/openrct2/openrct2-cli.post-install
deleted file mode 100644
index 3d0b9e718e..0000000000
--- a/testing/openrct2/openrct2-cli.post-install
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-cat <<EOF
-For OpenRCT2 to run you must install the assets from a retail copy of
-RollerCoaster Tycoon 2. See the following page for more information on
-installing a retail copy of the game on Linux:
-
- https://github.com/OpenRCT2/OpenRCT2/wiki/Installation-on-Linux,-macOS
-
-If kdialog or zenity is available, OpenRCT2 will prompt you for the location of
-the retail install the first time you start it.
-
-Alternatively, manually set the location of retail install:
-
- openrct2 set-rct2 /path/to/RCT2/
-EOF
diff --git a/testing/openrct2/openrct2.post-install b/testing/openrct2/openrct2.post-install
deleted file mode 100644
index 3d0b9e718e..0000000000
--- a/testing/openrct2/openrct2.post-install
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-cat <<EOF
-For OpenRCT2 to run you must install the assets from a retail copy of
-RollerCoaster Tycoon 2. See the following page for more information on
-installing a retail copy of the game on Linux:
-
- https://github.com/OpenRCT2/OpenRCT2/wiki/Installation-on-Linux,-macOS
-
-If kdialog or zenity is available, OpenRCT2 will prompt you for the location of
-the retail install the first time you start it.
-
-Alternatively, manually set the location of retail install:
-
- openrct2 set-rct2 /path/to/RCT2/
-EOF