aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openttd/APKBUILD
diff options
context:
space:
mode:
authorAdrian Siekierka <kontakt@asie.pl>2017-01-05 00:55:08 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-07 17:37:58 +0100
commit1e75d6e3db03b11e5ed787e7aee254c30f1c8352 (patch)
tree3272093b903613ed8070470aef1fcac1ad3b7f3e /testing/openttd/APKBUILD
parent14ea32ec9d03b049f04e58889c201336c8f42c06 (diff)
downloadaports-1e75d6e3db03b11e5ed787e7aee254c30f1c8352.tar.bz2
aports-1e75d6e3db03b11e5ed787e7aee254c30f1c8352.tar.xz
testing/openttd: new aport
http://openttd.org/ Open source simulation game based upon Transport Tycoon Deluxe
Diffstat (limited to 'testing/openttd/APKBUILD')
-rw-r--r--testing/openttd/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/testing/openttd/APKBUILD b/testing/openttd/APKBUILD
new file mode 100644
index 0000000000..02eb093a0c
--- /dev/null
+++ b/testing/openttd/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Adrian Siekierka <kontakt@asie.pl>
+# Maintainer: Adrian Siekierka <kontakt@asie.pl>
+pkgname=openttd
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="Open source simulation game based upon Transport Tycoon Deluxe"
+url="http://openttd.org/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="libpng-dev zlib-dev sdl-dev lzo-dev xz-dev freetype-dev fontconfig-dev"
+subpackages="$pkgname-doc $pkgname-lang::noarch"
+source="https://binaries.openttd.org/releases/1.6.1/openttd-1.6.1-source.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ # OpenTTD's builtin strip does not work when cross-compiling,
+ # but it will be done automatically later in the package build.
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --disable-strip \
+ --prefix-dir=/usr \
+ --binary-dir=bin \
+ --install-dir="${pkgdir}" \
+ --with-sdl \
+ --with-zlib \
+ --with-liblzma \
+ --with-liblzo2 \
+ --with-freetype \
+ --with-fontconfig \
+ --without-icu \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install || return 1
+}
+
+lang() {
+ pkgdesc="$pkgdesc (localizations)"
+
+ cd "$pkgdir"
+ mkdir -p "$subpkgdir"/usr/share/games/openttd/lang
+
+ local i
+ for i in $(find usr/share/games/openttd/lang/ ! -name 'english.lng' -type f); do
+ mv "$i" "$subpkgdir"/"$i" || return 1
+ done
+}
+
+md5sums="420c0488d2b085a1879ae2325e558310 openttd-1.6.1-source.tar.xz"
+sha256sums="9b08996e31c3485ef8dedfa1ab65147091593f3f11bd51eb7662ce5ea41363aa openttd-1.6.1-source.tar.xz"
+sha512sums="e0677c311e6567d130c1affc13c11fd81a742b588ee77e062a8f5816063b3da62fc2bc54eca4f243268266254358b06d9fea05f997468a33f201065e4ef4691a openttd-1.6.1-source.tar.xz"