aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-acunetix
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:21:57 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:21:57 +0000
commit9f34ef07235895abf436acc405892b720397f4b3 (patch)
treee74aecebfc164ce307b58ecb108cd73c969131dd /testing/ospd-acunetix
parent8cb7d861abb6d22e25dda7952a87370ff7113653 (diff)
downloadaports-9f34ef07235895abf436acc405892b720397f4b3.tar.bz2
aports-9f34ef07235895abf436acc405892b720397f4b3.tar.xz
testing/ospd-acunetix: new aport
Diffstat (limited to 'testing/ospd-acunetix')
-rw-r--r--testing/ospd-acunetix/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/ospd-acunetix/APKBUILD b/testing/ospd-acunetix/APKBUILD
new file mode 100644
index 0000000000..8328132a50
--- /dev/null
+++ b/testing/ospd-acunetix/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-acunetix
+pkgver=1.0b1
+pkgrel=0
+_pkgid=2181
+pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev cmake py-setuptools"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="155898fa60914ed84c9d09b28463417f ospd-acunetix-1.0b1.tar.gz"
+sha256sums="4c2b13056f38626952cc22b7b085025b237ee723d8b35bce2350ce51c52653ae ospd-acunetix-1.0b1.tar.gz"
+sha512sums="2a5b6fde959a890cd2084d1f8414639f8d281c3456239f101d1f353ec4044142cf71d7f7788a4d9aa0ce5d7a8a33204b785f5fd5d372d5c661e1ba9b9a447fd3 ospd-acunetix-1.0b1.tar.gz"