aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ancor
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-10-09 07:04:45 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-10-09 07:04:45 +0000
commit7e0248ed57419d5539a6ab4393f965dffdc75e63 (patch)
tree5b9a040121accc546d6b2b9ffa6d0ec73dcfc34e /testing/ospd-ancor
parent509cabcf69f8880a549bd70e77ba70c618dacc29 (diff)
downloadaports-7e0248ed57419d5539a6ab4393f965dffdc75e63.tar.bz2
aports-7e0248ed57419d5539a6ab4393f965dffdc75e63.tar.xz
testing/ospd-*: moved from community
Diffstat (limited to 'testing/ospd-ancor')
-rw-r--r--testing/ospd-ancor/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/ospd-ancor/APKBUILD b/testing/ospd-ancor/APKBUILD
new file mode 100644
index 0000000000..8cb4f83ff0
--- /dev/null
+++ b/testing/ospd-ancor/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ancor
+pkgver=1.0.0
+pkgrel=3
+_pkgid=2005
+pkgdesc="OSP server implementation to allow OpenVAS to get scan results from an Ancor server"
+url="http://openvas.org/"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python3 py3-requests ospd"
+makedepends="python3-dev py3-setuptools"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+md5sums="24b279b8928e4ff14bd33e7be4ebde8d ospd-ancor-1.0.0.tar.gz"
+sha256sums="b099325ef8c5d06fd58537930bd781d9c34d5d49688003b915b7c2f286711dc8 ospd-ancor-1.0.0.tar.gz"
+sha512sums="5bf23798c6bed4ba70e8f9c694c5870ef05d39a92091821687251e92df05363016a700dd9432c94646af7763bc7f6681b69a827f9bd8786a614a356d8c40602a ospd-ancor-1.0.0.tar.gz"