aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ancor
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:23:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:23:31 +0000
commitac87107a1c1d3fa654637537eda848b967596df5 (patch)
treebdbad9024c161b468e348c551e318ea3a88abf4c /testing/ospd-ancor
parent9f34ef07235895abf436acc405892b720397f4b3 (diff)
downloadaports-ac87107a1c1d3fa654637537eda848b967596df5.tar.bz2
aports-ac87107a1c1d3fa654637537eda848b967596df5.tar.xz
testing/ospd-ancor: new aport
Diffstat (limited to 'testing/ospd-ancor')
-rw-r--r--testing/ospd-ancor/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/ospd-ancor/APKBUILD b/testing/ospd-ancor/APKBUILD
new file mode 100644
index 0000000000..1ff64583ae
--- /dev/null
+++ b/testing/ospd-ancor/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ancor
+pkgver=1.0.0
+pkgrel=0
+_pkgid=2005
+pkgdesc="OSP server implementation to allow OpenVAS to get scan results from an Ancor server"
+url="http://openvas.org/"
+arch="noarch"
+license="GPLV2+"
+depends="python py-requests ospd"
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+md5sums="24b279b8928e4ff14bd33e7be4ebde8d ospd-ancor-1.0.0.tar.gz"
+sha256sums="b099325ef8c5d06fd58537930bd781d9c34d5d49688003b915b7c2f286711dc8 ospd-ancor-1.0.0.tar.gz"
+sha512sums="5bf23798c6bed4ba70e8f9c694c5870ef05d39a92091821687251e92df05363016a700dd9432c94646af7763bc7f6681b69a827f9bd8786a614a356d8c40602a ospd-ancor-1.0.0.tar.gz"