aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ikeprobe
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:27:35 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:27:35 +0000
commitbb89c582cdf278d7a83a66775cb339626d518a2b (patch)
tree90293ae8c42c4966cb8c43cc7d92ac09c1b7f0b4 /testing/ospd-ikeprobe
parent00573d09b54475c2a7d1b7803aa9deb9ca34ed73 (diff)
downloadaports-bb89c582cdf278d7a83a66775cb339626d518a2b.tar.bz2
aports-bb89c582cdf278d7a83a66775cb339626d518a2b.tar.xz
Revert "community/ospd-ikeprobe: moved from testing"
Diffstat (limited to 'testing/ospd-ikeprobe')
-rw-r--r--testing/ospd-ikeprobe/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/ospd-ikeprobe/APKBUILD b/testing/ospd-ikeprobe/APKBUILD
new file mode 100644
index 0000000000..5f0a4e9091
--- /dev/null
+++ b/testing/ospd-ikeprobe/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ikeprobe
+pkgver=1.0b1
+pkgrel=0
+_pkgid=2204
+pkgdesc="OSP server implementation to allow OpenVAS to remotely control a ikeprobe scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python ospd"
+depends_dev=""
+makedepends="$depends_dev cmake py-setuptools"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="97bc6b0953faf1e8883ee43360bf1e38 ospd-ikeprobe-1.0b1.tar.gz"
+sha256sums="86b29210b5c5b674352b8366a83b167c492c92e145a1637d28dd9a8f6a2ecde0 ospd-ikeprobe-1.0b1.tar.gz"
+sha512sums="567b2100ab42d7effe8fb47890a3c05fb7066ef97e29f2c723a3f29fd58addac220a91dda01804e997eec126905d43d59621b7318bfa02487ed789e228fe8660 ospd-ikeprobe-1.0b1.tar.gz"