aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-nmap
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-10-09 07:04:45 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-10-09 07:04:45 +0000
commit7e0248ed57419d5539a6ab4393f965dffdc75e63 (patch)
tree5b9a040121accc546d6b2b9ffa6d0ec73dcfc34e /testing/ospd-nmap
parent509cabcf69f8880a549bd70e77ba70c618dacc29 (diff)
downloadaports-7e0248ed57419d5539a6ab4393f965dffdc75e63.tar.bz2
aports-7e0248ed57419d5539a6ab4393f965dffdc75e63.tar.xz
testing/ospd-*: moved from community
Diffstat (limited to 'testing/ospd-nmap')
-rw-r--r--testing/ospd-nmap/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/ospd-nmap/APKBUILD b/testing/ospd-nmap/APKBUILD
new file mode 100644
index 0000000000..37eedb351f
--- /dev/null
+++ b/testing/ospd-nmap/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-nmap
+pkgver=1.0b1
+pkgrel=4
+_pkgid=2218
+pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python3"
+makedepends="cmake python3-dev py3-setuptools"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+
+md5sums="15b56da5a7282db6de7d6e534ec064e2 ospd-nmap-1.0b1.tar.gz"
+sha256sums="b3fc890fd13f459a5892cd465811289be61374b988ac6b983b05918f5a94d0ae ospd-nmap-1.0b1.tar.gz"
+sha512sums="f251d0951ba6225844274d26187aa7b90a654ed765471f356fa7979b623c5c04c7f7527dffb9e8f28e278c3e4079a7881947787435779c57d5346520934a9d21 ospd-nmap-1.0b1.tar.gz"