aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ssh-keyscan
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:35:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:35:04 +0000
commit4671ad321eca0537aa9be22ea79ab6dd58347e97 (patch)
treebb5238fd0eb31e5f1dc3ff02b5a4e2aef0d0d89c /testing/ospd-ssh-keyscan
parenta654312ea0596bc53ec41ace91b2b1bb0d96375c (diff)
downloadaports-4671ad321eca0537aa9be22ea79ab6dd58347e97.tar.bz2
aports-4671ad321eca0537aa9be22ea79ab6dd58347e97.tar.xz
testing/ospd-ssh-keyscan: new aport
Diffstat (limited to 'testing/ospd-ssh-keyscan')
-rw-r--r--testing/ospd-ssh-keyscan/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/ospd-ssh-keyscan/APKBUILD b/testing/ospd-ssh-keyscan/APKBUILD
new file mode 100644
index 0000000000..1a62e52be4
--- /dev/null
+++ b/testing/ospd-ssh-keyscan/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ssh-keyscan
+pkgver=1.0b1
+pkgrel=0
+_pkgid=2213
+pkgdesc="OSP server implementation to allow OpenVAS to scan ssh keys"
+url="http://openvas.org/"
+arch="noarch"
+license="GPLV2+"
+depends="python ospd"
+depends_dev=""
+makedepends="$depends_dev py-setuptools py-paramiko"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+md5sums="e78c2f1c4c5fe316f98637535db8cbdf ospd-ssh-keyscan-1.0b1.tar.gz"
+sha256sums="27a73979722e5ec09579cbf8a37228fc0c2a452597e21547244104d29a98950c ospd-ssh-keyscan-1.0b1.tar.gz"
+sha512sums="510a084ff93e2c6283ef21ea4c439077b15c9ada92f48cd0876fca87d430a4479b5700b536d68322cbcde7a1cc5109993706fae4d29e9ee61a7cb927450e5262 ospd-ssh-keyscan-1.0b1.tar.gz"