aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ossp-uuid
diff options
context:
space:
mode:
authorAndrzej Trzaska <atrzaska2@gmail.com>2018-09-28 23:19:02 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-11-16 15:31:09 +0200
commitb42a995a6683ff97db517eadaa75cc12fdfd77fd (patch)
tree6df5cca9aca4e54fae92d4a9b2b2c27795abd958 /testing/ossp-uuid
parent3e242f1e2745cb7e746a57b0c71d7c79108282c4 (diff)
downloadaports-b42a995a6683ff97db517eadaa75cc12fdfd77fd.tar.bz2
aports-b42a995a6683ff97db517eadaa75cc12fdfd77fd.tar.xz
testing/ossp-uuid: new aport
http://www.ossp.org/pkg/lib/uuid/ This package provides OSSP UUID library
Diffstat (limited to 'testing/ossp-uuid')
-rw-r--r--testing/ossp-uuid/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/ossp-uuid/APKBUILD b/testing/ossp-uuid/APKBUILD
new file mode 100644
index 0000000000..a18a9ecaa8
--- /dev/null
+++ b/testing/ossp-uuid/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: "Andrzej Trzaska <atrzaska2@gmail.com>"
+# Maintainer: "Andrzej Trzaska <atrzaska2@gmail.com>"
+pkgname=ossp-uuid
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="Open Source Software Project Universally Unique Identifier (UUID)"
+url="http://www.ossp.org/pkg/lib/uuid/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+source="https://mirrors.ocf.berkeley.edu/debian/pool/main/o/ossp-uuid/ossp-uuid_1.6.2.orig.tar.gz"
+builddir="$srcdir/uuid-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --without-pgsql --without-perl --without-php
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="16c7e016ce08d7679cc6ee7dec43a886a8c351960acdde99f8f9b590c7232d521bc6e66e4766d969d22c3f835dcc2814fdecc44eef1cd11e7b9b0f9c41b5c03e ossp-uuid_1.6.2.orig.tar.gz"