aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ostinato/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-05 10:16:12 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 13:04:16 +0000
commitba74c2c157d54f42715dea113e16a261821e485f (patch)
treed35cd7e7431d9caf6a3b6074c545d8659955eb0a /testing/ostinato/APKBUILD
parent34c5eaf34c440e4a13c158a3cf98a3163e34e170 (diff)
downloadaports-ba74c2c157d54f42715dea113e16a261821e485f.tar.bz2
aports-ba74c2c157d54f42715dea113e16a261821e485f.tar.xz
testing/ostinato: update to latest Git and move to Qt5
Diffstat (limited to 'testing/ostinato/APKBUILD')
-rw-r--r--testing/ostinato/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/testing/ostinato/APKBUILD b/testing/ostinato/APKBUILD
index b2a0f7ea80..1efd63acbb 100644
--- a/testing/ostinato/APKBUILD
+++ b/testing/ostinato/APKBUILD
@@ -1,31 +1,31 @@
# Maintainer: Corentin Henry <corentinhenry@gmail.com>
# Contributor: Corentin Henry <corentinhenry@gmail.com>
pkgname=ostinato
-pkgver=0.9
-pkgrel=1
+pkgver=0.9_git20190528
+pkgrel=0
+_commit="edc7ed677c1d5c308e66441f464dfd69aa922643"
pkgdesc="Packet/Traffic Generator and Analyzer"
url="https://www.ostinato.org"
arch="all"
license="GPL-3.0-or-later"
options="!check" # make test does nothing
-makedepends="qt-dev protobuf-dev libpcap-dev paxmark"
+makedepends="qt5-qtbase-dev protobuf-dev libpcap-dev qt5-qtscript-dev libnl3-dev"
subpackages="$pkgname-drone $pkgname-gui"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pstavirs/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$_commit.tar.gz::https://github.com/pstavirs/$pkgname/archive/$_commit.tar.gz
+ bug-265.patch
+ ModelTest.patch
+ "
+ # pstavirs/ostinato#265
+ # ModelTest::ModelTest is included and needed during linking even in release mode
+builddir="$srcdir/$pkgname-$_commit"
build() {
- cd "$builddir"
-
- qmake PREFIX=/usr
- make
+ qmake-qt5 PREFIX=/usr
+ make CXXFLAGS="$CXXFLAGS" # qmake generates broken CFLAGS, demand it use ours
}
package() {
- cd "$builddir"
-
make INSTALL_ROOT="$pkgdir" install
- paxmark -m "$pkgdir"/usr/bin/drone
- paxmark -m "$pkgdir"/usr/bin/ostinato
}
drone() {
@@ -42,4 +42,6 @@ gui() {
mv "$pkgdir"/usr/bin/ostinato "$subpkgdir"/usr/bin/ostinato
}
-sha512sums="a50f6e20d8a2a4d76ca43a89feaa774778981377ce1f4c731ad8b1a97aa658013082fb85cc3f4dfdd888d708c45c8093e55facaa7f02cecbd2ce5228f57e2e14 ostinato-0.9.tar.gz"
+sha512sums="b71bb38d9bd429198a0cce7f4abbe599f68ceb6a13d377aef437d12a972818f53ed67090191405f8b95538c9f2101fc20548f32258a1da1aca10a812fbd05a3c ostinato-edc7ed677c1d5c308e66441f464dfd69aa922643.tar.gz
+25ebe30724a22cbecada8e26b07dccbd4cbcf572e10988af11baa6dc9e4aeb31e6d332cb766f726626ef8ecc889ecaae083a540cdd41cc05edb4c354554cdced bug-265.patch
+e0a3d2781c62b1898a80af8522b36d6b1a7aeae9831c33c42e4e76fe002ee7ebff50d432508a18046d7b5988f09d9a9f90a0433cfae1d2c1cbeaf664671abf6c ModelTest.patch"