aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ostree
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-10 22:35:18 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-14 14:50:36 +0000
commita09926e0513aa1e7f3205051370b46dd840184fa (patch)
treee1cc8c582484342c1676248e29ee9577e5f3979d /testing/ostree
parentd8c4e94d57497b2d65456d57b5dc7f744705137c (diff)
downloadaports-a09926e0513aa1e7f3205051370b46dd840184fa.tar.bz2
aports-a09926e0513aa1e7f3205051370b46dd840184fa.tar.xz
testing/ostree: new aport
Diffstat (limited to 'testing/ostree')
-rw-r--r--testing/ostree/APKBUILD44
-rw-r--r--testing/ostree/musl-fixes.patch39
2 files changed, 83 insertions, 0 deletions
diff --git a/testing/ostree/APKBUILD b/testing/ostree/APKBUILD
new file mode 100644
index 0000000000..483afa1759
--- /dev/null
+++ b/testing/ostree/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=ostree
+pkgver=2017.3
+pkgrel=0
+pkgdesc="Operating system and container binary deployment and upgrades"
+url="https://github.com/ostreedev/ostree"
+arch="all"
+license="GPL"
+makedepends="bison glib-dev xz-dev libarchive-dev e2fsprogs-dev
+ libsoup-dev gpgme-dev fuse-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/ostreedev/ostree/releases/download/v$pkgver/libostree-$pkgver.tar.xz
+ musl-fixes.patch
+ "
+options="!check"
+builddir="$srcdir/lib$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --disable-static \
+ --disable-glibtest \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="eabb89b2c66395867feb516c07fdd71645570b9f145a535a6b3bb0d5612d300d4f22aede8332276023fb7439f14537a353722537c2e5a6a3c973bab72b8b87af libostree-2017.3.tar.xz
+24cf6d3d4681f95c84a76b77eb99d08dc56275142e4bb475708b2c74e8ad9633c26bf1ba73995cbf30d88c4c754bbbd1cb65e8f454359e2f6b2e6e53b6b48739 musl-fixes.patch"
diff --git a/testing/ostree/musl-fixes.patch b/testing/ostree/musl-fixes.patch
new file mode 100644
index 0000000000..4b1098e1ee
--- /dev/null
+++ b/testing/ostree/musl-fixes.patch
@@ -0,0 +1,39 @@
+--- a/src/libostree/ostree-repo.c
++++ b/src/libostree/ostree-repo.c
+@@ -43,6 +43,8 @@
+ #include <locale.h>
+ #include <glib/gstdio.h>
+
++#include <sys/file.h>
++
+ /**
+ * SECTION:ostree-repo
+ * @title: Content-addressed object store
+--- a/src/libostree/ostree-sysroot.c
++++ b/src/libostree/ostree-sysroot.c
+@@ -21,6 +21,7 @@
+ #include "config.h"
+
+ #include "otutil.h"
++#include <sys/file.h>
+ #include <sys/mount.h>
+ #include <sys/wait.h>
+
+--- a/config.h.in
++++ b/config.h.in
+@@ -148,3 +148,15 @@
+
+ /* Define to 1 if you need to in order for `stat' and other things to work. */
+ #undef _POSIX_SOURCE
++
++/* taken from glibc unistd.h and fixes musl */
++#ifndef TEMP_FAILURE_RETRY
++#define TEMP_FAILURE_RETRY(expression) \
++ (__extension__ \
++ ({ long int __result; \
++ do __result = (long int) (expression); \
++ while (__result == -1L && errno == EINTR); \
++ __result; }))
++#endif
++
++