aboutsummaryrefslogtreecommitdiffstats
path: root/testing/outils
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-10-03 02:10:15 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2015-10-03 02:38:00 +0200
commita79c1f0c6037dca29256221ce01311fb2a3d1f6e (patch)
tree30a77a869a4b9a58b96135dc7848e1870a6c5b7b /testing/outils
parent63f3fc7dbff44025cb380f0be3cc1131522f6713 (diff)
downloadaports-a79c1f0c6037dca29256221ce01311fb2a3d1f6e.tar.bz2
aports-a79c1f0c6037dca29256221ce01311fb2a3d1f6e.tar.xz
testing/outils: don't conflict with main/coreutils
Diffstat (limited to 'testing/outils')
-rw-r--r--testing/outils/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/outils/APKBUILD b/testing/outils/APKBUILD
index 1af1b4c208..77a7108285 100644
--- a/testing/outils/APKBUILD
+++ b/testing/outils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=outils
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Port of some non-standard OpenBSD tools to Linux"
url="https://github.com/chneukirchen/outils"
arch="all"
@@ -27,13 +27,17 @@ prepare() {
}
build() {
- cd "$_builddir"
- make CC="$CC" CFLAGS="$CFLAGS" || return 1
+ make CC="$CC" CFLAGS="$CFLAGS" \
+ -C "$_builddir" || return 1
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install \
+ -C "$_builddir" || return 1
+
+ # Don't conflict with main/coreutils
+ rm -f "$pkgdir"/usr/bin/cksum || return 1
+ rm -f "$pkgdir"/usr/share/man/man1/cksum.1 || return 1
}
md5sums="9b4be449ff568baedc3d3aac4dfaf6e0 outils-0.2.tar.gz