aboutsummaryrefslogtreecommitdiffstats
path: root/testing/outils
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-12-07 14:20:52 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2015-12-07 14:24:31 +0100
commitc3a5445898901deafd6b7ebedfd5e437c1850294 (patch)
tree7d12424e6c1695df74587045e0da0565907cec56 /testing/outils
parentcc1aed8e807b919744470e61dba9645574b0e04a (diff)
downloadaports-c3a5445898901deafd6b7ebedfd5e437c1850294.tar.bz2
aports-c3a5445898901deafd6b7ebedfd5e437c1850294.tar.xz
testing/outils: don't conflict with openssl
Diffstat (limited to 'testing/outils')
-rw-r--r--testing/outils/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/outils/APKBUILD b/testing/outils/APKBUILD
index 4dbb5bf13d..89d9049d2f 100644
--- a/testing/outils/APKBUILD
+++ b/testing/outils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=outils
pkgver=0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Port of some non-standard OpenBSD tools to Linux"
url="https://github.com/chneukirchen/outils"
arch="all"
@@ -31,9 +31,16 @@ package() {
make DESTDIR="$pkgdir" install \
-C "$_builddir" || return 1
- # Don't conflict with main/coreutils
+ # Don't conflict with main/coreutils.
rm -f "$pkgdir"/usr/bin/cksum || return 1
rm -f "$pkgdir"/usr/share/man/man1/cksum.1 || return 1
+
+ # Don't conflict with main/openssl.
+ # TODO: In the long run this conflict should be
+ # resolved in the openssl package instead.
+ for man in md5 sha1 sha256 sha512; do
+ rm -f "$pkgdir"/usr/share/man/man1/${man}.1 || return 1
+ done
}
md5sums="cb5d6274c78fd5dab8d5612668db08a3 outils-0.3.tar.gz"