aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pacparser
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 14:20:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 15:31:41 -0300
commit39270bba350c7df209ca94e0ea03328905f2e965 (patch)
treeb172789a253d94638a827202ea72015cbb5baa49 /testing/pacparser
parentf9a649cf2a0fcad0fadd3b67c3e0e80a54bb1a9b (diff)
downloadaports-39270bba350c7df209ca94e0ea03328905f2e965.tar.bz2
aports-39270bba350c7df209ca94e0ea03328905f2e965.tar.xz
testing/pacparser: switch to python3
Diffstat (limited to 'testing/pacparser')
-rw-r--r--testing/pacparser/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/testing/pacparser/APKBUILD b/testing/pacparser/APKBUILD
index 0ded41ab80..d1b5f48a78 100644
--- a/testing/pacparser/APKBUILD
+++ b/testing/pacparser/APKBUILD
@@ -2,18 +2,16 @@
# Maintainer: Aaron Hurt <ahurt@ena.com>
pkgname=pacparser
pkgver=1.3.7
-pkgrel=0
+pkgrel=1
pkgdesc="A library to parse proxy auto-config (PAC) files"
url="http://pacparser.manugarg.com"
# x86, armhf: https://github.com/pacparser/pacparser/issues/77
arch="x86_64"
license="LGPL-3.0-or-later"
-depends=""
-makedepends="bash python2-dev"
-subpackages="py-$pkgname:pymod $pkgname-doc $pkgname-dev"
+makedepends="bash python3-dev"
+subpackages="py3-$pkgname:pymod $pkgname-doc $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/pacparser/pacparser/archive/$pkgver.tar.gz
spidermonkey-make.patch"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
find "$builddir" -name \*.git\* -delete
@@ -21,28 +19,23 @@ prepare() {
}
build() {
- cd "$builddir"
-
# There's some concurrency problem, so we must disable parallel build.
# https://github.com/pacparser/pacparser/issues/27
- make -j1 -C src pactester pymod
+ PYTHON=python3 make -j1 -C src pactester pymod
}
package() {
- cd "$builddir"
make -C src DESTDIR="$pkgdir" install
}
pymod() {
- depends="python2"
+ depends="python3"
+ replaces="py-pymod" # Backwards compatibility
+ provides="py-pymod=$pkgver-r$pkgrel" # Backwards compatibility
cd "$builddir"
- make -C src DESTDIR="$subpkgdir" install-pymod
+ PYTHON=python3 make -C src DESTDIR="$subpkgdir" install-pymod
}
-md5sums="6ea7f2bf2e93eb7e8e58f75b77885c22 pacparser-1.3.7.tar.gz
-0d3415d45ea010e881b9ce439a84a736 spidermonkey-make.patch"
-sha256sums="575c5d8096b4c842b2af852bbb8bcfde96170b28b49f33249dbe2057a8beea13 pacparser-1.3.7.tar.gz
-6342cf7de9bb10f1804c54c67919436e5d7123ec52d1348ec94726e04b6a60a2 spidermonkey-make.patch"
sha512sums="9722dbfb0935824c5bea5f092e7bf82b74a0e59387e2a887d1c4e9234bcdb0af3ba4b58d5041dc6192e10200e46746481568a36bcdeca4860cdf00a921adfd2d pacparser-1.3.7.tar.gz
6f584acfb1f9f16385bef277f4c6bd30fa5f1e77d137cdd3306d50ce60e4917da34d47cd943ea078a264298dfa4a8c3256b447072dd108349e8deddfa536a60d spidermonkey-make.patch"