aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pass/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-03 00:56:13 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 18:34:19 +0000
commit2e90137d29365a435d2162cab225bbeafe0242f6 (patch)
treeabbaf8ebdac2261fca1ac63095473e40284da387 /testing/pass/APKBUILD
parentbd22d3a1f3a37efa434337cb00ec787cf76e40cc (diff)
downloadaports-2e90137d29365a435d2162cab225bbeafe0242f6.tar.bz2
aports-2e90137d29365a435d2162cab225bbeafe0242f6.tar.xz
testing/pass: modernize
- Add missing dependency on cmd:gpg - Enable tests, add missing dep on git - Use modern style
Diffstat (limited to 'testing/pass/APKBUILD')
-rw-r--r--testing/pass/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/testing/pass/APKBUILD b/testing/pass/APKBUILD
index 545fb00966..dda5c54415 100644
--- a/testing/pass/APKBUILD
+++ b/testing/pass/APKBUILD
@@ -3,15 +3,13 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=pass
pkgver=1.7.3
-pkgrel=0
+pkgrel=1
pkgdesc="Stores, retrieves, generates, and synchronizes passwords securely"
url="https://www.passwordstore.org"
arch="noarch"
license="GPL-2.0-or-later"
-depends="bash tree"
-depends_dev=""
-makedepends="$depends_dev"
-options="!check"
+depends="bash tree cmd:gpg2"
+checkdepends="git"
subpackages="$pkgname-doc
$pkgname-contrib
$pkgname-bash-completion:bashcomp
@@ -22,8 +20,11 @@ source="https://git.zx2c4.com/password-store/snapshot/password-store-$pkgver.tar
"
builddir="$srcdir/password-store-$pkgver"
+check() {
+ make test
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" \
WITH_ALLCOMP=yes install
install -Dm 644 "$srcdir"/README.alpine "$pkgdir"/usr/share/doc/pass/README.alpine