aboutsummaryrefslogtreecommitdiffstats
path: root/testing/patchelf
diff options
context:
space:
mode:
authorMichael Koloberdin <koloberdin@gmail.com>2016-07-09 06:39:59 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-12 08:30:36 +0200
commit6a2eb7d28225e2f8790e3360e4fff54572b97110 (patch)
treea4fdcfd3905af54b8f83360720db19ee0c7bbc0d /testing/patchelf
parentb5220a999e0544b5666b133e6ba13a93293b8269 (diff)
downloadaports-6a2eb7d28225e2f8790e3360e4fff54572b97110.tar.bz2
aports-6a2eb7d28225e2f8790e3360e4fff54572b97110.tar.xz
testing/patchelf: new aport
Diffstat (limited to 'testing/patchelf')
-rw-r--r--testing/patchelf/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/patchelf/APKBUILD b/testing/patchelf/APKBUILD
new file mode 100644
index 0000000000..735fff3364
--- /dev/null
+++ b/testing/patchelf/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor:
+# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
+pkgname=patchelf
+pkgver=0.9
+pkgrel=0
+pkgdesc="Small utility to modify the dynamic linker and RPATH of ELF executables"
+url="https://nixos.org/patchelf.html"
+arch="all"
+license="GPL3"
+depends=""
+makedepends="autoconf automake"
+install=""
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/NixOS/patchelf/archive/${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ autoreconf -fiv || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+check() {
+ make -C tests -j1 check || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="69c94a4400e930f938b754d543705eb9 patchelf-0.9.tar.gz"
+sha256sums="cf0693e794229e19edcf2299427b5a352e0f4d4f06f9d3856e30ddb0344d5ce8 patchelf-0.9.tar.gz"
+sha512sums="70e615f2f705f413aab5e3eebe20ffe79743bb92381b10a8faa49f16ca24b0f9bd4095c5644f682ec94d75012ffb1b39837933faa9f3c1f1c41bdc5b9d010a30 patchelf-0.9.tar.gz"