aboutsummaryrefslogtreecommitdiffstats
path: root/testing/patchelf
diff options
context:
space:
mode:
authorMichael Koloberdin <koloberdin@gmail.com>2016-07-10 00:31:54 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-12 08:30:36 +0200
commitceb5af6289749d07a61c832ecb5d333482029037 (patch)
treeedfda410c8a7d5f0c70b04076967768d1f8b70f7 /testing/patchelf
parent6a2eb7d28225e2f8790e3360e4fff54572b97110 (diff)
downloadaports-ceb5af6289749d07a61c832ecb5d333482029037.tar.bz2
aports-ceb5af6289749d07a61c832ecb5d333482029037.tar.xz
testing/patchelf: Fix the test that should not fail
Diffstat (limited to 'testing/patchelf')
-rw-r--r--testing/patchelf/APKBUILD18
-rw-r--r--testing/patchelf/fix-tests.patch14
2 files changed, 24 insertions, 8 deletions
diff --git a/testing/patchelf/APKBUILD b/testing/patchelf/APKBUILD
index 735fff3364..ed5b4fe3c7 100644
--- a/testing/patchelf/APKBUILD
+++ b/testing/patchelf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
pkgname=patchelf
pkgver=0.9
-pkgrel=0
+pkgrel=1
pkgdesc="Small utility to modify the dynamic linker and RPATH of ELF executables"
url="https://nixos.org/patchelf.html"
arch="all"
@@ -11,11 +11,13 @@ depends=""
makedepends="autoconf automake"
install=""
subpackages="$pkgname-doc"
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/NixOS/patchelf/archive/${pkgver}.tar.gz"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/NixOS/patchelf/archive/${pkgver}.tar.gz
+ fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
+ default_prepare
autoreconf -fiv || return 1
}
@@ -23,9 +25,6 @@ build() {
cd "$builddir"
./configure --prefix=/usr || return 1
make || return 1
-}
-
-check() {
make -C tests -j1 check || return 1
}
@@ -34,6 +33,9 @@ package() {
make DESTDIR="${pkgdir}" install || return 1
}
-md5sums="69c94a4400e930f938b754d543705eb9 patchelf-0.9.tar.gz"
-sha256sums="cf0693e794229e19edcf2299427b5a352e0f4d4f06f9d3856e30ddb0344d5ce8 patchelf-0.9.tar.gz"
-sha512sums="70e615f2f705f413aab5e3eebe20ffe79743bb92381b10a8faa49f16ca24b0f9bd4095c5644f682ec94d75012ffb1b39837933faa9f3c1f1c41bdc5b9d010a30 patchelf-0.9.tar.gz"
+md5sums="69c94a4400e930f938b754d543705eb9 patchelf-0.9.tar.gz
+39250eb2b2261bac6344b4e0bba08a9c fix-tests.patch"
+sha256sums="cf0693e794229e19edcf2299427b5a352e0f4d4f06f9d3856e30ddb0344d5ce8 patchelf-0.9.tar.gz
+7e8c1d25ee815ab0cd644c5cfe76f87b83877146a5e2252236ceb407fbcaf883 fix-tests.patch"
+sha512sums="70e615f2f705f413aab5e3eebe20ffe79743bb92381b10a8faa49f16ca24b0f9bd4095c5644f682ec94d75012ffb1b39837933faa9f3c1f1c41bdc5b9d010a30 patchelf-0.9.tar.gz
+f52c519e1b43481b44ac24060a05a1f027468627e9bf6e75055a1ae480f53a4ce141923adcaacea1370a8ef3bdbf12edbf479e348b6aecc0f0d1eba0cdf23ec8 fix-tests.patch"
diff --git a/testing/patchelf/fix-tests.patch b/testing/patchelf/fix-tests.patch
new file mode 100644
index 0000000000..386235a3e4
--- /dev/null
+++ b/testing/patchelf/fix-tests.patch
@@ -0,0 +1,14 @@
+diff -urp patchelf-0.9-orig/tests/set-rpath-library.sh patchelf-0.9/tests/set-rpath-library.sh
+--- patchelf-0.9-orig/tests/set-rpath-library.sh 2016-02-29 12:15:58.000000000 +0200
++++ patchelf-0.9/tests/set-rpath-library.sh 2016-07-10 03:09:55.365997370 +0300
+@@ -26,7 +26,9 @@ exitCode=0
+
+ if test "$exitCode" = 46; then
+ echo "expected failure"
+- exit 1
++# exit 1
++# As it is an "expected failure" the test should not exit but should go on.
++# See the comment below.
+ fi
+
+ # So set an RUNPATH on libfoo as well.