aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pavucontrol/APKBUILD
diff options
context:
space:
mode:
authorNoam Preil <pleasantatk@gmail.com>2019-08-19 01:29:29 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-08-19 02:42:27 -0300
commitd0cc1e278bac012e3f7da63f60d86bc1e2e1a85e (patch)
tree745a777bd1c9c3a5e415629e658a754bb0c7e51d /testing/pavucontrol/APKBUILD
parentc49c350abc6db75bba18746f6eaf73bb029f21d8 (diff)
downloadaports-d0cc1e278bac012e3f7da63f60d86bc1e2e1a85e.tar.bz2
aports-d0cc1e278bac012e3f7da63f60d86bc1e2e1a85e.tar.xz
testing/pavucontrol: new aport
https://freedesktop.org/software/pulseaudio/pavucontrol/ Pulseaudio Volume Control, GTK based mixer for Pulseaudio
Diffstat (limited to 'testing/pavucontrol/APKBUILD')
-rw-r--r--testing/pavucontrol/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/pavucontrol/APKBUILD b/testing/pavucontrol/APKBUILD
new file mode 100644
index 0000000000..edbd7bb7ad
--- /dev/null
+++ b/testing/pavucontrol/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Noam Preil <pleasantatk@gmail.com>
+pkgname="pavucontrol"
+pkgver="4.0"
+pkgrel=0
+pkgdesc="Pulseaudio Volume Control, GTK based mixer for Pulseaudio"
+url="https://freedesktop.org/software/pulseaudio/pavucontrol/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="pulseaudio"
+makedepends="m4 automake gtkmm3-dev glade-dev pulseaudio-dev"
+source="https://freedesktop.org/software/pulseaudio/pavucontrol/pavucontrol-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --datadir=/usr/share \
+ --disable-lynx \
+ --disable-nls
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fd58657d399349f22b52b55f946ea9e62f6278f087c945a54f4b61aa72fde92fb69f9bf7762f5db88235a0038535023faf92d8bb1f5d9f8b7168ccb2166386d3 pavucontrol-4.0.tar.gz"