aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pcsxr
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-10 05:07:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-10 05:13:19 -0300
commit77892117d9c249972f5e8a0cc93ece8a09576b97 (patch)
treec559027ba8e5d4f8c83da4e04aa1cff977c52b3c /testing/pcsxr
parent58b283e520ba84e2f35a41f28b5ccbd9639d1b93 (diff)
downloadaports-77892117d9c249972f5e8a0cc93ece8a09576b97.tar.bz2
aports-77892117d9c249972f5e8a0cc93ece8a09576b97.tar.xz
testing/pcsxr: upgrade to 1.9.95
Diffstat (limited to 'testing/pcsxr')
-rw-r--r--testing/pcsxr/APKBUILD34
-rw-r--r--testing/pcsxr/fix-assert-64bit.patch13
-rw-r--r--testing/pcsxr/fix-musl.patch14
-rw-r--r--testing/pcsxr/fix-uncompress2.patch23
-rw-r--r--testing/pcsxr/fix-undefined-operations.patch194
5 files changed, 266 insertions, 12 deletions
diff --git a/testing/pcsxr/APKBUILD b/testing/pcsxr/APKBUILD
index 7f439b465b..1ff0496cec 100644
--- a/testing/pcsxr/APKBUILD
+++ b/testing/pcsxr/APKBUILD
@@ -1,36 +1,46 @@
# Contributor: Cág <ca6c@bitmessage.ch>
# Maintainer: Cág <ca6c@bitmessage.ch>
pkgname=pcsxr
-pkgver=1.9.92
-pkgrel=2
+pkgver=1.9.95
+pkgrel=0
pkgdesc="Sony PlayStation emulator"
url="https://pcsxr.codeplex.com/"
arch="all"
license="GPL-3.0-or-later"
depends="libtxc_dxtn"
-makedepends="autoconf automake libglade-dev libtool gtk+2.0-dev sdl-dev mesa-dev
- libxv-dev libxtst-dev nasm libxxf86vm-dev"
+makedepends="autoconf automake libglade-dev libtool gtk+3.0-dev sdl-dev mesa-dev
+ libxv-dev libxtst-dev nasm libxxf86vm-dev libcdio-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="http://http.debian.net/debian/pool/main/p/pcsxr/pcsxr_1.9.92.orig.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
+source="
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/frealgagu/PCSX-Reloaded/archive/${pkgver}.tar.gz
+ fix-assert-64bit.patch
+ fix-undefined-operations.patch
+ fix-uncompress2.patch
+ fix-musl.patch
+ "
+builddir="$srcdir/PCSX-Reloaded-$pkgver/pcsxr"
prepare() {
- cd "$builddir"
default_prepare
- ./autogen.sh
+ mkdir include
+ autoreconf -fi
}
build() {
- cd "$builddir"
+ export CFLAGS="$CFLAGS -O2"
./configure \
--prefix=/usr \
- --enable-opengl
+ --enable-opengl \
+ --enable-libcdio
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="25b0caa1cc3715afddedfef7c069f4d334ce9f6bef9355c813c60b1462a2b68634d517a31373823d64a815bec4449234d13edb6ff5159f746820124d1993ef4c pcsxr_1.9.92.orig.tar.bz2"
+sha512sums="950f5776f1cf11d31c44cb5f47ab2480a4302ee01af5fa6a3bac0a96936ac280649c9456d78ddf75c038a43977114a780b259467cee5da7f84b8802ca1ec86a1 pcsxr-1.9.95.tar.gz
+ddd349a5e7ad5fea809596ccf44e4963992a4a9f96316db4d3c8211bc9d22ef3830115cd7b3b09d1c4c05e6419d21b2e81695d876352ea00128728709f66d58e fix-assert-64bit.patch
+1918231c3411eb2cedc3d3766d48bd766ee7aaaae34b964aec791f1e50851c7b367eb823cf0434e26e7ea8928becb30f7fcc88d27bf990072e9f651637d1f44e fix-undefined-operations.patch
+62593bc0c9422b025fdbcf04bbeff49fa195c8807cc44bc74555ad4d970e07054427299aed65bed0f75487c98e3a68ae78be86eb77822b1cf54ba26ba0e3e5ba fix-uncompress2.patch
+af69e67b12d3398248dab36f79552bff59a8246ea4aecd66f8e0621b7a1c3f5c5f03a16dc9f91b6b520290b5f688cbf7a3d9f3dbd4819f5f89dd1a5c20ccfb78 fix-musl.patch"
diff --git a/testing/pcsxr/fix-assert-64bit.patch b/testing/pcsxr/fix-assert-64bit.patch
new file mode 100644
index 0000000000..beb35b598d
--- /dev/null
+++ b/testing/pcsxr/fix-assert-64bit.patch
@@ -0,0 +1,13 @@
+diff --git a/pcsxr/libpcsxcore/ix86_64/ix86-64.c b/pcsxr/libpcsxcore/ix86_64/ix86-64.c
+index f48b742e..c69192e0 100644
+--- a/libpcsxcore/ix86_64/ix86-64.c
++++ b/libpcsxcore/ix86_64/ix86-64.c
+@@ -231,7 +231,6 @@ void x86SetJ8( u8* j8 )
+
+ if ( jump > 0x7f ) {
+ SysPrintf( "j8 greater than 0x7f!!\n" );
+- assert(0);
+ }
+ *j8 = (u8)jump;
+ }
+
diff --git a/testing/pcsxr/fix-musl.patch b/testing/pcsxr/fix-musl.patch
new file mode 100644
index 0000000000..cb5a18d7dc
--- /dev/null
+++ b/testing/pcsxr/fix-musl.patch
@@ -0,0 +1,14 @@
+diff --git a/plugins/dfinput/pad.c b/plugins/dfinput/pad.c
+index bd3aef7..2a01910 100644
+--- a/plugins/dfinput/pad.c
++++ b/plugins/dfinput/pad.c
+@@ -16,6 +16,8 @@
+ * along with this program; if not, see <http://www.gnu.org/licenses>.
+ */
+
++#include <fcntl.h>
++
+ #include "pad.h"
+ #if !SDL_VERSION_ATLEAST(2,0,0) && defined(__linux__)
+ #include <linux/input.h>
+
diff --git a/testing/pcsxr/fix-uncompress2.patch b/testing/pcsxr/fix-uncompress2.patch
new file mode 100644
index 0000000000..439f2c5adf
--- /dev/null
+++ b/testing/pcsxr/fix-uncompress2.patch
@@ -0,0 +1,23 @@
+diff --git a/pcsxr/libpcsxcore/cdriso.c b/pcsxr/libpcsxcore/cdriso.c
+index b7eedea2..8ad16d15 100644
+--- a/libpcsxcore/cdriso.c
++++ b/libpcsxcore/cdriso.c
+@@ -1146,7 +1146,7 @@ static int cdread_sub_mixed(FILE *f, unsigned int base, void *dest, int sector)
+ return ret;
+ }
+
+-static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned long in_size)
++static int uncompress2_internal(void *out, unsigned long *out_size, void *in, unsigned long in_size)
+ {
+ static z_stream z;
+ int ret = 0;
+@@ -1225,7 +1225,7 @@ static int cdread_compressed(FILE *f, unsigned int base, void *dest, int sector)
+ if (is_compressed) {
+ cdbuffer_size_expect = sizeof(compr_img->buff_raw[0]) << compr_img->block_shift;
+ cdbuffer_size = cdbuffer_size_expect;
+- ret = uncompress2(compr_img->buff_raw[0], &cdbuffer_size, compr_img->buff_compressed, size);
++ ret = uncompress2_internal(compr_img->buff_raw[0], &cdbuffer_size, compr_img->buff_compressed, size);
+ if (ret != 0) {
+ SysPrintf("uncompress failed with %d for block %d, sector %d\n",
+ ret, block, sector);
+
diff --git a/testing/pcsxr/fix-undefined-operations.patch b/testing/pcsxr/fix-undefined-operations.patch
new file mode 100644
index 0000000000..cd15906a02
--- /dev/null
+++ b/testing/pcsxr/fix-undefined-operations.patch
@@ -0,0 +1,194 @@
+diff --git a/pcsxr/plugins/peopsxgl/texture.c b/pcsxr/plugins/peopsxgl/texture.c
+index 8d8fb41b..0d313b97 100644
+--- a/plugins/peopsxgl/texture.c
++++ b/plugins/peopsxgl/texture.c
+@@ -1002,7 +1002,10 @@ void LoadStretchPackedWndTexturePage(int pageid, int mode, short cx, short cy)
+ if(ldy)
+ {ldy--;
+ for(TXU=g_x1;TXU<=g_x2;TXU++)
+- *ta++=*(ta-(g_x2-g_x1));
++ {
++ *ta=*(ta-(g_x2-g_x1));
++ ta++;
++ }
+ }
+ }
+
+@@ -1079,7 +1082,10 @@ void LoadStretchPackedWndTexturePage(int pageid, int mode, short cx, short cy)
+ if(ldy)
+ {ldy--;
+ for(TXU=g_x1;TXU<=g_x2;TXU++)
+- *ta++=*(ta-(g_x2-g_x1));
++ {
++ *ta=*(ta-(g_x2-g_x1));
++ ta++;
++ }
+ }
+
+ }
+@@ -1204,7 +1210,10 @@ void LoadStretchWndTexturePage(int pageid, int mode, short cx, short cy)
+ if(ldy)
+ {ldy--;
+ for(TXU=g_x1;TXU<=g_x2;TXU++)
+- *ta++=*(ta-(g_x2-g_x1));
++ {
++ *ta=*(ta-(g_x2-g_x1));
++ ta++;
++ }
+ }
+ }
+
+@@ -1288,7 +1297,10 @@ void LoadStretchWndTexturePage(int pageid, int mode, short cx, short cy)
+ if(ldy)
+ {ldy--;
+ for(TXU=g_x1;TXU<=g_x2;TXU++)
+- *ta++=*(ta-(g_x2-g_x1));
++ {
++ *ta=*(ta-(g_x2-g_x1));
++ ta++;
++ }
+ }
+
+ }
+@@ -2247,14 +2259,19 @@ GLuint LoadTextureMovie(void)
+ lu=*((uint32_t *)pD);pD+=3;
+ *ta++=XMBLUE(lu)|XMGREEN(lu)|XMRED(lu)|1;
+ }
+- *ta++=*(ta-1);
++ *ta=*(ta-1);
++ ta++;
+ }
+ if(b_Y)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0+1;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
+- *ta++=*(ta-1);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
++ *ta=*(ta-1);
++ ta++;
+ }
+ }
+ else
+@@ -2273,7 +2290,10 @@ GLuint LoadTextureMovie(void)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
+ }
+ }
+ }
+@@ -2296,14 +2316,19 @@ GLuint LoadTextureMovie(void)
+ *ta++=((c&0x1f)<<11)|((c&0x3e0)<<1)|((c&0x7c00)>>9)|1;
+ }
+
+- *ta++=*(ta-1);
++ *ta=*(ta-1);
++ ta++;
+ }
+ if(b_Y)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0+1;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
+- *ta++=*(ta-1);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
++ *ta=*(ta-1);
++ ta++;
+ }
+ }
+ else
+@@ -2321,7 +2346,10 @@ GLuint LoadTextureMovie(void)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
+ }
+ }
+ }
+@@ -2347,14 +2375,19 @@ GLuint LoadTextureMovie(void)
+ *ta++=*((uint32_t *)pD)|0xff000000;
+ pD+=3;
+ }
+- *ta++=*(ta-1);
++ *ta=*(ta-1);
++ ta++;
+ }
+ if(b_Y)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0+1;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
+- *ta++=*(ta-1);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
++ *ta=*(ta-1);
++ ta++;
+ }
+ }
+ else
+@@ -2373,7 +2406,10 @@ GLuint LoadTextureMovie(void)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
+ }
+ }
+ }
+@@ -2394,15 +2430,20 @@ GLuint LoadTextureMovie(void)
+ startxy=((1024)*column)+xrMovieArea.x0;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+ *ta++=LTCOL(psxVuw[startxy++]|0x8000);
+- *ta++=*(ta-1);
++ *ta=*(ta-1);
++ ta++;
+ }
+
+ if(b_Y)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0+1;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
+- *ta++=*(ta-1);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
++ *ta=*(ta-1);
++ ta++;
+ }
+ }
+ else
+@@ -2418,7 +2459,10 @@ GLuint LoadTextureMovie(void)
+ {
+ dx=xrMovieArea.x1-xrMovieArea.x0;
+ for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
+- *ta++=*(ta-dx);
++ {
++ *ta=*(ta-dx);
++ ta++;
++ }
+ }
+ }
+ }
+