aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pdal/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:35:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 17:25:32 -0300
commit536559404d7022a86c9295008cbbb392dce30fe7 (patch)
tree34d38de93faf2a2a9410510e3eac9cdcd66aca96 /testing/pdal/APKBUILD
parentf10e5639666ff935feaffcf148038d3b01834835 (diff)
downloadaports-536559404d7022a86c9295008cbbb392dce30fe7.tar.bz2
aports-536559404d7022a86c9295008cbbb392dce30fe7.tar.xz
testing/pdal: fix dependencies
Diffstat (limited to 'testing/pdal/APKBUILD')
-rw-r--r--testing/pdal/APKBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/testing/pdal/APKBUILD b/testing/pdal/APKBUILD
index 1a0c619070..28f307f9b2 100644
--- a/testing/pdal/APKBUILD
+++ b/testing/pdal/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="PDAL is a C++ BSD library for translating and manipulating point cloud
url="https://pdal.io"
arch="x86_64"
license="BSD-2-Clause"
-depends="nitro python py-numpy>=1.14.3-r1"
+depends="nitro python3 py3-numpy>=1.14.3-r1"
makedepends="
cmake
eigen-dev
@@ -18,8 +18,8 @@ makedepends="
laz-perf-dev
libgeotiff-dev
libxml2-dev
- python-dev
- py-numpy-dev
+ python3-dev
+ py3-numpy-dev
jsoncpp-dev
hdf5-dev
proj-dev
@@ -65,12 +65,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-dev() {
- default_dev
- mv "$subpkgdir"/usr/lib/*.so.* "$pkgdir"/usr/lib/
- rm -r "$subpkgdir"/usr/lib
-}
-
check() {
cd "$builddir"/build
make test