aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-archive-extract
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:01:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:01:57 -0300
commit351398340874103c711da825a3d09b8b1925fa54 (patch)
tree3c5b52bd3e1c6ee60ec4ed890bea75a47d6bb4f3 /testing/perl-archive-extract
parentf7bf64d3b4681d13e52ec6937ae094db3de93b10 (diff)
downloadaports-351398340874103c711da825a3d09b8b1925fa54.tar.bz2
aports-351398340874103c711da825a3d09b8b1925fa54.tar.xz
testing/perl-archive-extract: fix url fix license
Diffstat (limited to 'testing/perl-archive-extract')
-rw-r--r--testing/perl-archive-extract/APKBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/testing/perl-archive-extract/APKBUILD b/testing/perl-archive-extract/APKBUILD
index 1defd6af54..d472d5a550 100644
--- a/testing/perl-archive-extract/APKBUILD
+++ b/testing/perl-archive-extract/APKBUILD
@@ -4,43 +4,34 @@
pkgname=perl-archive-extract
_pkgreal=Archive-Extract
pkgver=0.80
-pkgrel=0
+pkgrel=1
pkgdesc="Generic archive extracting mechanism"
-url="http://search.cpan.org/dist/Archive-Extract/"
+url="search.cpan.org/dist/Archive-Extract/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}