aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-astro-suntime
diff options
context:
space:
mode:
authorFrancesco <fcolista@cf1844j.(none)>2011-02-03 13:52:05 +0100
committerLeonardo Arena <rnalrd@gmail.com>2011-02-25 09:50:42 +0000
commit0981f3ad44e885fa2cc81c597460ed201c948abe (patch)
treea3631d93741af3732232f0fe4d9a7b2f3dcb02eb /testing/perl-astro-suntime
parentb04699fa8cf6b8d10f88b2109bbcb3c595d2b1bf (diff)
downloadaports-0981f3ad44e885fa2cc81c597460ed201c948abe.tar.bz2
aports-0981f3ad44e885fa2cc81c597460ed201c948abe.tar.xz
testing/perl-astro-suntime: new aport
testing/perl-device-serialport: new aport testing/perl-time-parsedate: new aport testing/perl-x10: new aport
Diffstat (limited to 'testing/perl-astro-suntime')
-rw-r--r--testing/perl-astro-suntime/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/perl-astro-suntime/APKBUILD b/testing/perl-astro-suntime/APKBUILD
new file mode 100644
index 0000000000..501925e4fc
--- /dev/null
+++ b/testing/perl-astro-suntime/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-astro-suntime
+_realname=Astro-SunTime
+pkgver=0.01
+pkgrel=0
+pkgdesc="Provides a function interface to calculate sun rise/set times."
+url="http://search.cpan.org/dist/Astro-SunTime/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev perl-time-parsedate"
+install=
+subpackages=""
+source="http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="4657927a49604494bfaaa153663b90b9 Astro-SunTime-0.01.tar.gz"