aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-bind-config-parser
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:04:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:04:26 -0300
commitae289a2b6a6848783222df3b6f5a8591c87a9809 (patch)
tree3d8ba9718c2fee3aa461a87d82e66beaac55f8bf /testing/perl-bind-config-parser
parent5fc4e600f6729328b561ecffebb73991038760ca (diff)
downloadaports-ae289a2b6a6848783222df3b6f5a8591c87a9809.tar.bz2
aports-ae289a2b6a6848783222df3b6f5a8591c87a9809.tar.xz
testing/perl-bind-config-parser: fix url fix license
Diffstat (limited to 'testing/perl-bind-config-parser')
-rw-r--r--testing/perl-bind-config-parser/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/testing/perl-bind-config-parser/APKBUILD b/testing/perl-bind-config-parser/APKBUILD
index 79d9461f1b..c5dd89fba4 100644
--- a/testing/perl-bind-config-parser/APKBUILD
+++ b/testing/perl-bind-config-parser/APKBUILD
@@ -4,37 +4,32 @@
pkgname=perl-bind-config-parser
_pkgreal=BIND-Config-Parser
pkgver=0.01
-pkgrel=1
+pkgrel=2
pkgdesc="Parse BIND Config file"
-url="http://search.cpan.org/dist/BIND-Config-Parser/"
+url="https://metacpan.org/release/BIND-Config-Parser"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-parse-recdescent"
-cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MA/MATTD/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}