aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-conf-libconfig
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:53:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:53:07 -0300
commit00ac2a19b2066ac3d55139b3218d4862526164b0 (patch)
treec0dee6ff086005c0d1bbac2c73f66fd9f51c0856 /testing/perl-conf-libconfig
parentd69ae775b846f69f43121409196b43814b990102 (diff)
downloadaports-00ac2a19b2066ac3d55139b3218d4862526164b0.tar.bz2
aports-00ac2a19b2066ac3d55139b3218d4862526164b0.tar.xz
testing/perl-conf-libconfig: modernize, comment on license=
Diffstat (limited to 'testing/perl-conf-libconfig')
-rw-r--r--testing/perl-conf-libconfig/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/testing/perl-conf-libconfig/APKBUILD b/testing/perl-conf-libconfig/APKBUILD
index bb434a4960..46d87abae1 100644
--- a/testing/perl-conf-libconfig/APKBUILD
+++ b/testing/perl-conf-libconfig/APKBUILD
@@ -8,30 +8,25 @@ pkgrel=2
pkgdesc="Perl extension for libconfig"
url="https://metacpan.org/release/Conf-Libconfig/"
arch="all"
-license="bsd"
+license="bsd" # Not an actual license, there are lots of BSD licenses
cpanmakedepends="perl-extutils-pkgconfig perl-test-deep perl-test-exception perl-test-warn"
-depends="$cpandepends"
makedepends="perl-dev libconfig-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/C/CN/CNANGEL/Conf-Libconfig-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}