aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-cpan-changes
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-28 09:53:54 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-28 09:53:54 +0000
commitcb1f6e3ebeeb2bf9c11faea71a0e16131ff3aee5 (patch)
tree3e71bbc920ea3c80843176e2dd93572df6a8aa62 /testing/perl-cpan-changes
parent21f16ad077681315e5da1031596a3332ef553079 (diff)
downloadaports-cb1f6e3ebeeb2bf9c11faea71a0e16131ff3aee5.tar.bz2
aports-cb1f6e3ebeeb2bf9c11faea71a0e16131ff3aee5.tar.xz
testing/perl-cpan-changes: new aport
Diffstat (limited to 'testing/perl-cpan-changes')
-rw-r--r--testing/perl-cpan-changes/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/perl-cpan-changes/APKBUILD b/testing/perl-cpan-changes/APKBUILD
new file mode 100644
index 0000000000..c8adfb18f4
--- /dev/null
+++ b/testing/perl-cpan-changes/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-cpan-changes
+_pkgreal=CPAN-Changes
+pkgver=0.400002
+pkgrel=0
+pkgdesc="Read and write Changes files"
+url="http://search.cpan.org/dist/CPAN-Changes/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="5773d51abaafd37c6bcdde3827873075 CPAN-Changes-0.400002.tar.gz"
+sha256sums="01eedea90d07468cb58e4a50bfa3bb1d4eeda9073596add1118fc359153abe8d CPAN-Changes-0.400002.tar.gz"
+sha512sums="d359073d9d5ed2126835d4895c1ee5288cc09e72202ba77441bb25cf13e9cd0f16d4040b7e2cf1785efd6e8ccbe7908415fb4fefeebe9c0548d838d2ac850dfb CPAN-Changes-0.400002.tar.gz"