aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-crypt-passwdmd5
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-03-23 13:07:00 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-25 21:25:48 +0000
commit9a5387aca8869e13adc5c84b2663d7afc1ce5b42 (patch)
treec099b3742b2ea52fc378164b1b802e288e55add3 /testing/perl-crypt-passwdmd5
parent8ca582921f3e2e2f50c3284be6ea70fb9ade9763 (diff)
downloadaports-9a5387aca8869e13adc5c84b2663d7afc1ce5b42.tar.bz2
aports-9a5387aca8869e13adc5c84b2663d7afc1ce5b42.tar.xz
perl-crypt-passwdmd5 new aport
Diffstat (limited to 'testing/perl-crypt-passwdmd5')
-rw-r--r--testing/perl-crypt-passwdmd5/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-crypt-passwdmd5/APKBUILD b/testing/perl-crypt-passwdmd5/APKBUILD
new file mode 100644
index 0000000000..cfa717fef6
--- /dev/null
+++ b/testing/perl-crypt-passwdmd5/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-crypt-passwdmd5
+_pkgreal=Crypt-PasswdMD5
+pkgver=1.40
+pkgrel=0
+pkgdesc="Provide interoperable MD5-based crypt() functions"
+url="https://metacpan.org/release/Crypt-PasswdMD5/"
+arch="noarch"
+license="GPL PerlArtistic"
+makedepends="perl-dev perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/R/RS/RSAVAGE/Crypt-PasswdMD5-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="c00f76210a9c07ad610b4698b15d142c3859100a13af620919e32bf046ab2febf8ebedafcffa4dde62f7e9af0e9ff137dae623e0bab60380fca003f7b35bfc77 Crypt-PasswdMD5-1.40.tgz"