aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-data-dumper-concise
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-28 00:49:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-28 00:49:04 -0300
commit1c128096e06aaa365ba848266272b06eb0ac7fb1 (patch)
tree1228ea07f88a308b49f5d4e95a499f50f6909471 /testing/perl-data-dumper-concise
parent045352cb9f15fbf784cbec55d2978cab57856107 (diff)
downloadaports-1c128096e06aaa365ba848266272b06eb0ac7fb1.tar.bz2
aports-1c128096e06aaa365ba848266272b06eb0ac7fb1.tar.xz
testing/perl-data-dumper-concise: fix url fix license
Diffstat (limited to 'testing/perl-data-dumper-concise')
-rw-r--r--testing/perl-data-dumper-concise/APKBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/testing/perl-data-dumper-concise/APKBUILD b/testing/perl-data-dumper-concise/APKBUILD
index f2afed8ce5..3ef32d4f07 100644
--- a/testing/perl-data-dumper-concise/APKBUILD
+++ b/testing/perl-data-dumper-concise/APKBUILD
@@ -4,43 +4,34 @@
pkgname=perl-data-dumper-concise
_pkgreal=Data-Dumper-Concise
pkgver=2.023
-pkgrel=0
+pkgrel=1
pkgdesc="Less indentation and newlines plus sub deparsing"
-url="http://search.cpan.org/dist/Data-Dumper-Concise/"
+url="https://metacpan.org/release/Data-Dumper-Concise"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}