aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-file-find-rule
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 17:32:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 17:32:01 +0000
commit3a26d2b0c379537b8798b89316a86cb403433a12 (patch)
tree3ec58b20050116d0ee64b8f0f1964024cc7e72f0 /testing/perl-file-find-rule
parent7e4a7bd706b2391c34cf1da50f42e81ab1f2df59 (diff)
downloadaports-3a26d2b0c379537b8798b89316a86cb403433a12.tar.bz2
aports-3a26d2b0c379537b8798b89316a86cb403433a12.tar.xz
testing/perl-file-find-rule: new aport
Diffstat (limited to 'testing/perl-file-find-rule')
-rw-r--r--testing/perl-file-find-rule/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/perl-file-find-rule/APKBUILD b/testing/perl-file-find-rule/APKBUILD
new file mode 100644
index 0000000000..808713c076
--- /dev/null
+++ b/testing/perl-file-find-rule/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-file-find-rule
+_pkgreal=File-Find-Rule
+pkgver=0.34
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/File-Find-Rule/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-text-glob perl-number-compare"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RC/RCLAMP/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="a7aa9ad4d8ee87b2a77b8e3722768712 File-Find-Rule-0.34.tar.gz"
+sha256sums="7e6f16cc33eb1f29ff25bee51d513f4b8a84947bbfa18edb2d3cc40a2d64cafe File-Find-Rule-0.34.tar.gz"
+sha512sums="97328a86578942d214f7ac530cc88fc84dc7ef2018db06b8c0c58907a4045e90c9c97d1848ed4f16838bd8ca591aca4fa9f24649c81fd8dfe9efe7a2f9f2722c File-Find-Rule-0.34.tar.gz"