aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-locale-codes/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-05-23 00:13:14 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 21:22:29 +0000
commit1aa76bb0ca302ba4bf61736e1bb7bd12a6a226f6 (patch)
treeab8ee82e094eeac494910e9635f7c5ba44e6a62f /testing/perl-locale-codes/APKBUILD
parent1738a57560a1bf773934d7fb27aebf5b3adbc7cb (diff)
downloadaports-1aa76bb0ca302ba4bf61736e1bb7bd12a6a226f6.tar.bz2
aports-1aa76bb0ca302ba4bf61736e1bb7bd12a6a226f6.tar.xz
testing/perl-locale-codes: new aport
Closes GH-8010
Diffstat (limited to 'testing/perl-locale-codes/APKBUILD')
-rw-r--r--testing/perl-locale-codes/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/perl-locale-codes/APKBUILD b/testing/perl-locale-codes/APKBUILD
new file mode 100644
index 0000000000..a1f71564d3
--- /dev/null
+++ b/testing/perl-locale-codes/APKBUILD
@@ -0,0 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-locale-codes
+_pkgreal=Locale-Codes
+pkgver=3.60
+pkgrel=0
+pkgdesc="a distribution of modules to handle locale codes"
+url="https://metacpan.org/release/Locale-Codes/"
+arch="noarch"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SB/SBECK/Locale-Codes-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="3994ea6073cbcc3118fba64f3a9d3bd82276b4fe9f0eccf9e457f052850a00f28e78df36e0306e4e7ba58bc1f9ad58b884c64d53e1c911b6e98b1f2875ef5906 Locale-Codes-3.60.tar.gz"