aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-net-netmask
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-25 13:01:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-25 13:01:06 +0000
commit21293a9abc82f63fb1f8f695d7f43a2938857770 (patch)
treed317ca223357615b652ca10a80e5e2d2d789db41 /testing/perl-net-netmask
parentb7db7261abf7927859b6f39e55b91be446bf2073 (diff)
downloadaports-21293a9abc82f63fb1f8f695d7f43a2938857770.tar.bz2
aports-21293a9abc82f63fb1f8f695d7f43a2938857770.tar.xz
testing/perl-net-netmask: modernize and add check
Diffstat (limited to 'testing/perl-net-netmask')
-rw-r--r--testing/perl-net-netmask/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/testing/perl-net-netmask/APKBUILD b/testing/perl-net-netmask/APKBUILD
index 798a420148..d1cbd6c77a 100644
--- a/testing/perl-net-netmask/APKBUILD
+++ b/testing/perl-net-netmask/APKBUILD
@@ -3,31 +3,33 @@
pkgname=perl-net-netmask
_realname=Net-Netmask
pkgver=1.9022
-pkgrel=0
+pkgrel=1
pkgdesc="Perl extension to parse, manipulate, and lookup IP network blocks"
url="http://search.cpan.org/~muir/Net-Netmask-1.9016/"
arch="noarch"
license="PerlArtistic"
depends="perl"
-depends_dev=""
makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/$_realname-$pkgver.tar.gz"
-builddir="$srcdir"/$_realname-$pkgver
+
+builddir="$srcdir/$_realname-$pkgver"
build() {
cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="67cee41e2214bd0934ff96944b29130c Net-Netmask-1.9022.tar.gz"
-sha256sums="07099c1ff4de752e6f5420b32de12e4338b05bbb252e53c782b740173ba31533 Net-Netmask-1.9022.tar.gz"
sha512sums="85778356c0eb5047a1f8ce9883fe61dec4f54180571eefff0d08a723f6f8f828b5c6a52015de751bc13fc340275a5bc220668a37086bc4a62f164ed93f6e087f Net-Netmask-1.9022.tar.gz"