aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-snmp-info/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 12:01:46 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commitb46efc6431f66209bcc122c884d9c5f1c5ed61df (patch)
tree57a893c318258f6b7411c80175ac8630e2f40938 /testing/perl-snmp-info/APKBUILD
parentdeb3ccae0c5befe7b365c50d6666b201692d2e69 (diff)
downloadaports-b46efc6431f66209bcc122c884d9c5f1c5ed61df.tar.bz2
aports-b46efc6431f66209bcc122c884d9c5f1c5ed61df.tar.xz
testing/perl-snmp-info: new aport
http://search.cpan.org/dist/SNMP-Info/
Diffstat (limited to 'testing/perl-snmp-info/APKBUILD')
-rw-r--r--testing/perl-snmp-info/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/perl-snmp-info/APKBUILD b/testing/perl-snmp-info/APKBUILD
new file mode 100644
index 0000000000..07c5f7e98b
--- /dev/null
+++ b/testing/perl-snmp-info/APKBUILD
@@ -0,0 +1,47 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-snmp-info
+_pkgreal=SNMP-Info
+pkgver=3.36
+pkgrel=0
+pkgdesc="OO Interface to Network devices and MIBs through SNMP"
+url="http://search.cpan.org/dist/SNMP-Info/"
+arch="noarch"
+license="bsd"
+cpandepends="net-snmp-perl"
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/O/OL/OLIVER/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ ./Build
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+sha512sums="392eab1553075fbb07305a3ba6e4dc01f896d78a928d3058127ee336f1adf663af6c9cf125dffad47b2764b21d486cf33422b7ea0832a65e431aade4436b80af SNMP-Info-3.36.tar.gz"