aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-compile
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 17:35:33 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 17:35:33 +0000
commit12639887678f113b38f63914225c2d2765e8185c (patch)
tree973cd48b1b59a23178e65dd880ca537808b73f98 /testing/perl-test-compile
parent788041d95f1cace6af186d0a3c6df3915638bd19 (diff)
downloadaports-12639887678f113b38f63914225c2d2765e8185c.tar.bz2
aports-12639887678f113b38f63914225c2d2765e8185c.tar.xz
testing/perl-test-compile: new aport
Diffstat (limited to 'testing/perl-test-compile')
-rw-r--r--testing/perl-test-compile/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/perl-test-compile/APKBUILD b/testing/perl-test-compile/APKBUILD
new file mode 100644
index 0000000000..357b20674c
--- /dev/null
+++ b/testing/perl-test-compile/APKBUILD
@@ -0,0 +1,45 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-compile
+_pkgreal=Test-Compile
+pkgver=v1.3.0
+pkgrel=0
+pkgdesc="Perl module for Test-Compile"
+url="http://search.cpan.org/dist/Test-Compile/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-module-build perl-devel-checkos perl-module-build
+ perl-test-warnings perl-universal-require"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/E/EG/EGILES/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="c7e8c9255d818823d440ac640527e7f8 Test-Compile-v1.3.0.tar.gz"
+sha256sums="77527e9477ac5260443c756367a7f7bc3d8f6c6ebbc561b0b2fb3f79303bad33 Test-Compile-v1.3.0.tar.gz"
+sha512sums="58396ed37a668ad005955193dfdad435d4b92f16334ed83f1ec5de8e1046bef8eec452ccefa277311f8eb903c7872fcc6ebacfeba112621f8b8ca05841089ef8 Test-Compile-v1.3.0.tar.gz"