aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-exception/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-15 09:41:15 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-15 09:41:15 +0000
commitd8f59fe889c444197b1e6b255ad3790d17e66c9b (patch)
treed87bdec91ac1f56f44c51a35780ee879c8b42093 /testing/perl-test-exception/APKBUILD
parentbd5df205483a38140e3d4073f4c83c5e3c1496ed (diff)
parentac0b8f00d40d62169ab0c2f88f2b5996d4b61447 (diff)
downloadaports-d8f59fe889c444197b1e6b255ad3790d17e66c9b.tar.bz2
aports-d8f59fe889c444197b1e6b255ad3790d17e66c9b.tar.xz
Merge git://dev.alpinelinux.org/aports
Diffstat (limited to 'testing/perl-test-exception/APKBUILD')
-rw-r--r--testing/perl-test-exception/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/perl-test-exception/APKBUILD b/testing/perl-test-exception/APKBUILD
new file mode 100644
index 0000000000..27edda25a6
--- /dev/null
+++ b/testing/perl-test-exception/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer:
+pkgname=perl-test-exception
+_pkgreal=Test-Exception
+pkgver=0.31
+pkgrel=0
+pkgdesc="Perl module for testing exception-using code"
+url="http://search.cpan.org/dist/Test-Exception/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends=
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="adb57ca7614d15e5b307bf5e024b35a8 Test-Exception-0.31.tar.gz"