aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-fatal
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-11-26 21:22:03 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:35 -0500
commiteb69f1c5602b8935ad357ed08c3c8729f6c4a6c1 (patch)
treeff7bd5684ff6ab60b14b7e76c5c0da220077282e /testing/perl-test-fatal
parent8a7826b7be87b7f97ec5b7760a24a8bad420f46e (diff)
downloadaports-eb69f1c5602b8935ad357ed08c3c8729f6c4a6c1.tar.bz2
aports-eb69f1c5602b8935ad357ed08c3c8729f6c4a6c1.tar.xz
testing/perl-test-fatal: new APKBUILD
Diffstat (limited to 'testing/perl-test-fatal')
-rw-r--r--testing/perl-test-fatal/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-test-fatal/APKBUILD b/testing/perl-test-fatal/APKBUILD
new file mode 100644
index 0000000000..4af1de9b3a
--- /dev/null
+++ b/testing/perl-test-fatal/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-test-fatal
+_pkgreal=Test-Fatal
+pkgver=0.008
+pkgrel=0
+pkgdesc="incredibly simple helpers for testing code with exceptions"
+url="http://search.cpan.org/dist/Test-Fatal/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-try-tiny"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="201c94efbbcbd38b32e3cdc6752a6c07 Test-Fatal-0.008.tar.gz"