aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-utf8
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2018-01-06 16:33:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-27 17:43:24 +0000
commit341613adc6c770987a69b9a09a54db09e0b62c12 (patch)
tree72c7db3c52a0c86cc94665a7824bbcca1d20ee54 /testing/perl-test-utf8
parent6992ce388c4c443a5ed7221b4a3a1c6236ed15c8 (diff)
downloadaports-341613adc6c770987a69b9a09a54db09e0b62c12.tar.bz2
aports-341613adc6c770987a69b9a09a54db09e0b62c12.tar.xz
testing/perl-test-utf8: new aport
Diffstat (limited to 'testing/perl-test-utf8')
-rw-r--r--testing/perl-test-utf8/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-test-utf8/APKBUILD b/testing/perl-test-utf8/APKBUILD
new file mode 100644
index 0000000000..8a3affeaae
--- /dev/null
+++ b/testing/perl-test-utf8/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=perl-test-utf8
+_realname=Test-utf8
+pkgver=1.01
+pkgrel=0
+pkgdesc="A collection of tests useful for dealing with utf8 strings"
+url="https://github.com/2shortplanks/Test-utf8"
+arch="noarch"
+license="PerlArtistic"
+depends=""
+makedepends="perl-dev perl-module-install"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MA/MARKF/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="07dcd5ed98a63f7d96bb0fc629b168773d02bb4c93c5bc44ec60738fc29669794547dfde5913f9de682cd583cf85f4d82b6151398aaebcfec9278525447b9c4e Test-utf8-1.01.tar.gz"