aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-text-aspell
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-03-29 21:12:26 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-03 12:46:46 +0000
commit0a3d991a0604d20461e91801f400238ece2972b1 (patch)
treeb30275f01e1efb04630261bc5183256dbfb8baca /testing/perl-text-aspell
parent12bc190a208634dbc5fd89c7e08839db1e7fa712 (diff)
downloadaports-0a3d991a0604d20461e91801f400238ece2972b1.tar.bz2
aports-0a3d991a0604d20461e91801f400238ece2972b1.tar.xz
testing/perl-text-aspell: new aport
Diffstat (limited to 'testing/perl-text-aspell')
-rw-r--r--testing/perl-text-aspell/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-text-aspell/APKBUILD b/testing/perl-text-aspell/APKBUILD
new file mode 100644
index 0000000000..5b23979d57
--- /dev/null
+++ b/testing/perl-text-aspell/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=perl-text-aspell
+_pkgreal=Text-Aspell
+pkgver=0.09
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/Text-Aspell/"
+arch="all"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends aspell-dev"
+checkdepends="$cpancheckdepends aspell-en"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/H/HA/HANK/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="6e7f2a8f48f3d735d9162333c4d30a0ffcdc4a002cffc51f284759a1e89e0a79c0bf94e2af577f381613a114f1ede134f01db36367d443a81ba8d028a4a8c65b Text-Aspell-0.09.tar.gz"