aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-text-aspell
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-03 07:17:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-03 07:17:39 -0300
commit06aff7c26479258cfc44bd9456ffc309583b683c (patch)
treebdf21eed111d9dbad97467e5698b9475317e38ee /testing/perl-text-aspell
parent99e55d561aa57f3631a1c01894f6d5d0aeb81775 (diff)
downloadaports-06aff7c26479258cfc44bd9456ffc309583b683c.tar.bz2
aports-06aff7c26479258cfc44bd9456ffc309583b683c.tar.xz
testing/perl-text-aspell: fix url fix license
Diffstat (limited to 'testing/perl-text-aspell')
-rw-r--r--testing/perl-text-aspell/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/testing/perl-text-aspell/APKBUILD b/testing/perl-text-aspell/APKBUILD
index d76fec728c..e8cd13a9ac 100644
--- a/testing/perl-text-aspell/APKBUILD
+++ b/testing/perl-text-aspell/APKBUILD
@@ -4,17 +4,13 @@
pkgname=perl-text-aspell
_pkgreal=Text-Aspell
pkgver=0.09
-pkgrel=1
+pkgrel=2
pkgdesc="Perl interface to the GNU Aspell library"
-url="http://search.cpan.org/dist/Text-Aspell/"
+url="https://metacpan.org/release/Text-Aspell"
arch="all"
-license="GPL-1.0-or-later Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends aspell-dev"
-checkdepends="$cpancheckdepends aspell-en"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev aspell-dev"
+checkdepends="aspell-en"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/H/HA/HANK/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -22,25 +18,21 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}