aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-tie-ixhash
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-03 07:00:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-03 07:00:31 -0300
commitd091400a226e29f5241a91572c88abc9dc59da63 (patch)
treeb1bc6a07f6e32b576d4daf5ee3682bff3db0a5c4 /testing/perl-tie-ixhash
parenta04f7eab13be1862e265e021316295f5ad335ff1 (diff)
downloadaports-d091400a226e29f5241a91572c88abc9dc59da63.tar.bz2
aports-d091400a226e29f5241a91572c88abc9dc59da63.tar.xz
testing/perl-tie-ixhash: fix url fix license
Diffstat (limited to 'testing/perl-tie-ixhash')
-rw-r--r--testing/perl-tie-ixhash/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/testing/perl-tie-ixhash/APKBUILD b/testing/perl-tie-ixhash/APKBUILD
index 232d6ea732..2a3569cb08 100644
--- a/testing/perl-tie-ixhash/APKBUILD
+++ b/testing/perl-tie-ixhash/APKBUILD
@@ -4,34 +4,33 @@
pkgname=perl-tie-ixhash
_pkgreal=Tie-IxHash
pkgver=1.23
-pkgrel=0
+pkgrel=1
pkgdesc="ordered associative arrays for Perl"
-url="http://search.cpan.org/dist/Tie-IxHash/"
+url="https://metacpan.org/release/Tie-IxHash"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpanmakedepends="perl-module-build"
-depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/C/CH/CHORNY/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ ./Build
+}
+
+check() {
+ /Build test
}
package() {
- cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}