aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-uri-escape
diff options
context:
space:
mode:
authorLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:34 +0000
committerLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:34 +0000
commit48fc19666521ef4207f29c6513af2aef1c7446aa (patch)
tree58771c777ca9dc022c7758835891a468852f6e97 /testing/perl-uri-escape
parent1c823be22d48ffeec4899983252020562c95c3ce (diff)
downloadaports-48fc19666521ef4207f29c6513af2aef1c7446aa.tar.bz2
aports-48fc19666521ef4207f29c6513af2aef1c7446aa.tar.xz
testing/perl-uri-escape: new aport
Diffstat (limited to 'testing/perl-uri-escape')
-rw-r--r--testing/perl-uri-escape/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/perl-uri-escape/APKBUILD b/testing/perl-uri-escape/APKBUILD
new file mode 100644
index 0000000000..84d43a798e
--- /dev/null
+++ b/testing/perl-uri-escape/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-uri-escape
+_realname=URI
+pkgver=1.38
+pkgrel=0
+pkgdesc="Uniform Resource Identifiers (absolute and relative)"
+url="http://search.cpan.org/~gaas/URI-1.38/"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ rm $pkgdir/usr/lib/perl5/5.10.0/x86_64-linux/perllocal.pod
+}
+
+md5sums="35fba2715eb8ac56e8e30244ae69ff65 URI-1.38.tar.gz"